I am updating my Xcode 4.5.x to Xcode 4.6 directly from Mac App Store. But I am unable to update it. First it downloads the new Xcode. After downloading, it starts installing. But while installing it gets stuck at 2 minutes and the installation time counter changes abruptly between 2 minutes to 17 minutes. After some time, the installation stops and the Xcode 4.6 download starts again. This process is repeating since last night. Anyone else having the same issue. I have updated my Xcode from App Store previously also, but never had any issues.

  • I am having the same problem. I have tried the most basic stuff like restarting etc but no luck.
    – Alex
    Commented Jan 30, 2013 at 7:40
  • I don't know what Apple guys are doing out there. I am gonna keep trying until I file a bug.
    – Evol Gate
    Commented Jan 30, 2013 at 8:53

4 Answers 4


You can download the DMG separately this time. You do not have to go through the App store, but it requires a free Developer account.

1) Log into the Mac Developer Center
2) Scroll down to the "Xcode 4.6" section.
3) On the right there is a button to download Xcode 4.
4) Open the DMG.
5) Drag the old Xcode from the Applications folder to the Trash.
6) Drag the new Xcode from the mounted volume to the Applications folder.

This time it will download a DMG file instead of a link to the Mac App Store.

Either way you will have to download reinstall any extras from within Xcode itself. See the Preferences -> Downloads tab to finish the install.

  • 1
    When I tried this the only button that appeared in the "Xcode 4.6" section was a "View in Mac App Store" button. To get the direct download I had to follow the "View All Downloads" link in the "Additional Downloads" section. That brought up a list of available downloads, which included Xcode 4.6.
    – aroth
    Commented Feb 19, 2013 at 23:21

Since Xcode is now looking a lot more like a sandboxed app that gets downloaded to /Applications and sits there forever, it's probably just a download issue where the App Store is not smart enough to know if the application is running or quit, so you might need to reboot and be sure Xcode doesn't launch at log in time.

You could help things by moving Xcode to the trash before the reboot - but this shouldn't be much different than troubleshooting any other App Store download.


Unless you get a definite error message, it might be an overload issue on the server side as well and something you just might need to keep hammering away at until you get an actual error message from the App Store app.

  • In my case restarting and or/quitting Xcode did not work(having the same problem as Evol Gate). These suggestions in the troubleshooting guide did not help me unfortunately. Do you have any more suggestions on how to solve this?
    – Alex
    Commented Feb 5, 2013 at 11:46

I was experiencing the same problem recently. I solved it by killing the iTunesHelper process, quitting all other apps, and waiting for it to finish the installation. It took a while to complete (~5-10 min).


I have experienced something similar by changing internet connections during a download, but I don't think that's the case here. So best thing to do is:

First try to repair disk permissions using "Disk Utility". If it didn't work, then delete the XCode and install it again rather than updating it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .