Okay, I have the weirdest problem. All the apps in my 'Purchases' tab show either 'Install' or 'Download', most of the apps I currently have installed, but non the less it doesn't recognise them. This holds true for brand new apps (installed yesterday) and ones I've had since I installed ML. I'd really like to get the apps recognised, so that I can get updates for them.

I've scoured the internet far and wide and haven't even been able to find any similar problems.

I really wish someone has an answer :)

Update: Deleting and reinstalling an app has no effect. It shows installed at first, but switching tabs and coming back to 'Purchases' renders it back to 'Install'.

Update: `CKSoftwareMap: updateRequestBodyData:includeInstalledApps:includeBundledApps:conditionally:hadUnadoptedApps:waitUntilMapIsLoaded: timed out waiting for mdSemaphore``

This is the "culprit" from Console.app and seems to be dependent on Spotlight indexes. Still don't know what corrupts my spotlight indexes...

  • Did you move the app from the application folder?
    – Tony
    Commented Jan 29, 2013 at 16:08
  • Nope, all my app's are in the application folder. And it's not really an app, it's all apps which I have "purchased"
    – deiga
    Commented Jan 29, 2013 at 16:09
  • Have you tried deleting an app and redownloading it to see if it fixes it? Also try this suggestion, reviews.cnet.com/8301-13727_7-20028985-263.html
    – Tony
    Commented Jan 29, 2013 at 16:11
  • @Tony Too bad none of the methods in your link helped :(
    – deiga
    Commented Jan 29, 2013 at 16:33

2 Answers 2


You'll want to focus on problems with either Spotlight finding the apps or perhaps an overall disk structure failure.

Unless you are going in and systematically modifying each app's receipt, the App Store should find apps using spotlight and correctly reflect the status assuming both the disk doesn't need repair and the spotlight index is current.

  • Okay, I found another post that points to the Spotlight indexes (insanelymac.com/forum/topic/279751-app-store-broken). So now I'm waiting for the re-indexing to finish (3h to go...)
    – deiga
    Commented Jan 29, 2013 at 18:52
  • If you're impatient, you can exclude all user home folders by adding /Users to the privacy pane - the system should be able to index the core files in less than 30 minutes. You'll still need to wait hours for the bulk of the drive to pass through the data detectors, but at least your irritation will be solved or we'll have eliminated the likely culprit.
    – bmike
    Commented Jan 29, 2013 at 18:55
  • I haven't been feeling impatient, so I still got 20 mins left. I've been noticing my Console.app cluttering up with errors messages from spotlight. mds[36]: (Error) Task: Can't init <MDSClient 0x7f8eb68d6e70 shutdown:NO got shutdown notification:NO> -- too many objects for MDSTaskRegistry and mdworker[3995]: (Warning) Worker: Unable to fetch debug levels from server. Continuing with default debug levels. (268435459: (ipc/send) invalid destination port)
    – deiga
    Commented Jan 29, 2013 at 20:19
  • Grr - those often mean there's a problem with one of the data importers or a file causing spotlight to bomb out. We're straying into "diagnosing spotlight" and I'll just point out that mddiagnose is a nice tool to collect tons of logs, and trial/error can often point out where in the directory tree Spotlight gives up - sometimes a problem with one file prevents others from being scanned.
    – bmike
    Commented Jan 29, 2013 at 20:24
  • As we already suspected, the rebuilding of indexes and disk repair (nothing to repair) and disk permissions had absolutely no effect. Trying to wade through mddiagnose logs and maybe spot something...
    – deiga
    Commented Jan 29, 2013 at 21:08

I'd like to add to the possible solutions… I had the same problem. Turns out I also had a Windows disk installed that I needed some files from. I kept seeing errors in system.log like "Error getting quotas for volume /Volumes/...".

I powered off, disconnected the Windows disk, and rebooted. Voila! App Store can now search for updates and identifies installed purchases under the "Purchases" tab.

I hope I can save someone time, this problem has been plaguing me for a few days now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .