I have a late 2009 Mac Book Pro 13" running 10.6.8. Using WiFi I can not load websites in any browser (Chrome, Firefox, Safari) it is as if I am not connected to the computer. I can do FTP transfers (most of the time) and stream music via Spotify (pretty much all of the time.) Everything functions properly when connecting to the same network with an ethernet cable. In the house we have one more mac, a linux box and an assortment of iOS devices, none of which have any problems connecting to the same network via WiFi.

Resetting the PRAM generally solves the problem, but it reapears everytime, sometimes in days, sometimes in a matter of minutes. I tried wiping the hard drive and reinstalling a fresh verison of OS X, which didn't help at all. I also tried connecting with a cheap USB Wifi dongle. That worked, but was very slow, and stopped working after about 45 minutes of use.

How can this be? What can I do about this? Can anyone recomend a good USB WiFi adapter compatible with OS X?

UPDATE: I fixed this by switching to DHCP with manual IP address and selecting a new IP address. The problem then migrated to my iPad2 (iOS 5.x) when it claimed that IP, but the same fix worked there. It never effected any of the iPhones in the house (iOS 5.1 jailbroken and iOS 6.x not jailbroken) or the other MacBook (10.8.x). The mystery remains, but the internets work so I try not to worry about it.

  • What error does the browser give you specifically? – iracigt Jan 28 '13 at 22:46
  • You may try resetting your WiFi to DHCP and Renew Lease (I believe through advanced settings). If you stay with a manual IP address, be sure it is one that isn't in the routers DHCP range, to avoid potential conflicts. For instance, if your router dishes out, select – bispymusic Mar 1 '13 at 22:28
  • If the same IP would suggest your router has an issue - perhaps a firewall on http protocol or port 80 – mmmmmm Mar 1 '13 at 22:39

Hi the problem is with your DNS settings the Mac you are using cannot resolve the request into an IP address. If you look at the other Macs in your house you should copy down the settings and opens System Preferences, Network and compare the settings. If your mac is set for DHCP then your router is not passing on the DNS settings of your ISP, or if it is the same as the Router then the Router cannot act as a DNS server, choose the DNS IP of your ISP that is sure to work.

  • The DNS servers were set the same on my MacBook as on my wife's, which never had a problem. – JPollock Mar 1 '13 at 22:20

Not the answer you're looking for? Browse other questions tagged .