I am having issues where an external USB3 drive(#1) is not showing up after reboot. It also doesnt not show up when holding option during boot. This external drive is a clone made with Carbon Copy Cloner. I have cloned the recovery partition as well using CCC. The external disk is not ecrypted, but the Macbook I am doing this from is with Filevault2. It shows up properly when connected as long as I don't restart the OS. If the OS is restarted, the drive will not show up in Finder, Disk Utility, System Information, or Terminal. But when I disconnect the drive and connect it again it shows up and mounts.

I fixed drive #2 issue by deleting my Time Machine backup from the Time Machine System Preferences and as soon as I connected it, showed up and asked for password. Well now I know nothing is wrong with my USB3, but still would like to know why I can't boot drive #1.

My other issue is another external USB3 drive(#2) from the same company, but more expensive model. This is my Time Machine backup. It is encrypted using the Time Machine GUI in system preferences. It doesn't ask for my password when plugged in. I have used it many times before. This drive will not show up in Finder, Disk Utility, System Information or Terminal when plugged in. Obviously it needs my password to decrypt the volume, but why isn't it asking me? The drive has sufficient power.

Obviously there is something going on with my Mac. Please help and let me know if you need more information. Also both of these external enclosures have worked great with this Macbook and my previous Macbook. Never had an issue. Macsales is not known for low quality or poorly designed products IMO.

System Info for my Macbook

Additional Sys Info

System Information for drive #1

Disk Utility drive #1

Disk Utility filesystem #1

  • I have reformatted the drive with same settings. Also doing a fresh clone. I have read that after Filevault is enabled, RecoveryHD partition will not show up when option is held during startup. Well I know this is true because I have not seen it. There was also mention that to see the RecoveryHD partition, command+r must be held during startup instead. I will try this and see it the external drive shows up then. That still doesn't explain the drive not mounting or showing up at all in disk utility after restart of OS.
    – aknewhope
    Jan 27 '13 at 23:24

So far, it seems that my MacBook doesn't recognize USB3 before login. If I plug either my Time Machine or clone which are both USB3 into a USB2 hub, both are recognized at boot using either option or command+r. You could also use a regular USB2 cable to force to USB2. This is not unusual as my Windows desktop I built is the same because the BIOS doesn't support USB3 yet. The USB3 functionality is implemented through a separate chip from the Processor or Chipset. I wonder if this is the same for MacBooks....


Could be USB 3.0 flakiness. I really like the speed when it works, but I have run into quirks. Review this official Using USB 3 devices on Mac computers FAQ from Apple to see if it offers any insight.

In my case, I have a 2012 Mac mini. USB 3.0. But I have USB 1.0 & USB 2.0 devices connected directly to the Mac mini. Cold start from shutdown or reboot? The USB 3.0 devices are recognized, but only as “high speed” USB 2.0 devices & not “super speed” USB 3.0 devices. The solution? Unmount the drive, power down the enclusore or remove the USB cable, replug it in & power it up. And then the drive shows up as a “super speed” USB 3.0 device. Very annoying.

Apple’s FAQ addresses USB 3.0 speed slowing down to the slowest USB device, but not this weirdo mix where it’s mis-recognizes the device speed on startup or reboot but is properly recognized on a running machine but only if the drive is plugged in or powered on after boot.

EDIT: So reread and saw the mention of Filevault2 and Carbon Copy Cloner. This thread on the Carbon Copy Cloner support forum seems to be apt to this issue. Long story short, when you say:

The external disk is not ecrypted, but the Macbook I am doing this from is with Filevault2.

If you make an exact clone of an encrypted volume, the copy is encrypted.

  • It's possible the flakiness is on my Macbook. I guess I could use a USB2 cable because the USB3 port is made to do that. Then the Macbook would see it as USB2. I have no USB2 cables with me right now but can try tomorrow, but like I said above on my edited question, I have used both of these in the exact same configuration on the same Macbook many times.
    – aknewhope
    Jan 28 '13 at 0:10
  • I just reread your post. Specifcially about Filevault2. I think that is the key. Have edited my answer with more info. Jan 28 '13 at 0:25
  • When I make a clone, the clone is unencrypted. My boot drive becomes unencrypted when I login to my Macbook. I wanted to encrypt the external clone drive #1. I read the instructions from CCC support pages. To do so with Filevault, I need to make a clone my Macbook drive and recovery partition. Then I need to boot into the external drive #1. Then go to System Preferences and enable Filevault. Then I boot back into my normal Macbook boot drive and the external drive #1 is encrypted using Filevault as well.
    – aknewhope
    Jan 28 '13 at 2:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .