I'm having some issues and I feel as though I have literally tried everything. I am at a complete loss on what to do.


I had multiple Mac computers including this one for a while. All working fine with router.

Then I replaced my router because it was getting slow and dated, the new one I got worked fine at first, but then started to drop connection every other day and even sometimes every day. I replaced the replacement router, then my macbook air had ridiculously slow connection speed. It would take google 5-10 minutes to load. But my iMac computer worked fine. I didn't change anything, nor do anything different to either computer except get this new router. The router even managed to corrupt my time machine. So I called up the ISP and they worked me through the issues, so now everything is working fine EXCEPT my Macbook Air.

I have tried starting from scratch with the router, with the Time Machine, I have rebooted all devices. But the internet remains the same. It's good on my iMac, my phone, my TV, but not the macbook air. I wanted to call Apple, but it costs $60 to talk to a someone which is not affordable for me. I am really frustrated with this.

I went through all the changes with my Airport Utility. I even reset my Macbook Air to factory default settings. Still I have the same issue.

What can I do to troubleshoot this problem?

  • 1
    Hey Sam :) What router is it? What year is the Macbook Air? Do all the current macs in your household have the same o/s? Have you tried changing the channel on your router? It could be a possible network adapter (since it's not even letting you connect to the router itself). What band is it on? E.g. A/B/G/N etc.. Also, have you tried to connect the Air to the router via an ethernet cable?
    – Phorce
    Commented Jan 27, 2013 at 0:24

4 Answers 4


Have you tried going to the Network preference pane in System Preferences, clicking on Advanced, then Wi-Fi, and deleting all the Preferred Networks? I seem to recall having the same problem a few years ago, and deleting the networks fixed it.

  • additionally to be extra sure, after deleting all saved networks, I turned off my Mac's bluetooth and rebooted it before reconnecting Commented Mar 18, 2020 at 10:12

Deleting all networks in Mac, System Preferences, Network fixed the identical problem for me.


The following are all suggestions I've tried from different sources:

What actually helped was to reset the SMC and reset the PRAM. Now the Mac connects instantly to the WiFi. And it fixed the ping delays as well I had (ping times were up to 4 times higher than from another Macbook).


With seven years of experience in the technical industry I troubleshooted this error for a very long time and was very frustrated! The only thing that fixed it was this

  1. Login to your router and reset all settings
  2. connect to your router with no wifi security
  3. once you confirm that the wireless connected fine, then
  4. setup your wifi router with WPA and reconfigure your passphrase/wifi password again
  5. re-connect to your secured wifi

After doing this I now have internet. I hope this helps. I know this solution makes no sense, but I tried everything on the internet and nothing else did it.

  • Starting over and redoing things is often a good solution, especially with configurations which have a lot of parameters to consider.
    – nohillside
    Commented Mar 20, 2014 at 15:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .