Under the 'settings' -> 'mail contacts calendars' -> gmail

there is no option to sync the contacts

what's the workaround?

  1. Open settings
  2. Tap Mail, Contacts, Calendars.
  3. Tap Add Account,
  4. Tap Other,
  5. Tap Add CardDAV account.
  6. Enter google.com for the server, and your login info.
  7. Tap Done.

This will bring your Google contacts in, and it is smart enough to show you a unified view of your Google contacts with your Apple ones. I.E., if you have someone in both sets, they show up as one contact, and you can see which pieces of data came from each. It works very well for me.


If You are using Mac OS X, you can synchronize you Contacts on Mac with google (set it i Contacts settings). Then just synchronize with your iPhone via iTunes.

You must log in to answer this question.

protected by Community Jul 10 '13 at 11:48

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .