Long story short; I was updating a couple of iPad apps via iTunes last night, but had to shut down. Now they're all listed as "installing..." on my iPad but they're neither being downloaded nor installed, and I can't access them until they're finished (but they're not progressing, so they won't finish).

Is there any way to abort an in-progress update so I can at least use the apps I've currently got?


This is addressed several times on the Apple Forums. It is a common problem. I will list a few of the answers that have worked for others. Before starting, do the obligatory iPad reboot.

1) From the iPad desktop click the stalled app. It will either restart the update process or report the "update failed". If it fails you will then be able to restart the update from within iPads App updater.

2) If you have a desktop Mac, from iTunes go to menu Store > Check for Available Downloads. This should download the updated App to your iTunes. Then re-sync with your iPad.

3) Delete the app from your iPad then reinstall.

I found that option 1 worked flawlessly for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .