On a black iPhone 4, I open the Game Center application and it is stuck on "loading":

enter image description here

For a moment I assumed that it was a problem with Apple. Well, no, because turns out I have a white iPhone 4 where Game Center does work.

I heard that if an iPhone is jailbroken, you can't use Game Center for developing applications on sandbox mode. However, it does work for normal games. Both of my devices are jailbroken.

Why might my black iPhone be stuck on "loading" within the Game Center application, while the other device works just fine with it?

There is a difference in iOS version though. The black iPhone, which is stuck on the loading screen, is 6.0.1, while the white one, which works, is 4.3.3.

I already tried rebooting the black iPhone and killing the Game Center application.

  • Drastic measure, but when all else fails, restore. :/ – daviesgeek Jan 25 '13 at 4:15
  • Jailbreaking doesn't affect Game Center. The only app that requires a special bit of attention from JB creators is iBooks. – user10355 Jan 25 '13 at 8:14
  • I have the same problem when ever I try to go on clash of clans the gamecenter sign in pops up and when I sign in it loads but never stops loading I have a black iPod touch 4g iOS 6.0.1 – user45265 Mar 16 '13 at 2:49
  • Wanted to confirm that there is indeed an issue with developing for GameCenter sandbox on a jailbroken device. Haven't found out the why/how yet, but it's real. – producerism Aug 22 '13 at 21:31

iPhone 4 GSM Black:

I had the same issue when I updated to 6.1.2 from my previous version 5.1.1 when the evasi0n jailbreak came out. I solved the problem by restoring to the factory default. Then I went through the beginning steps of the iphone introduction, when i open and logged in to gamecenter everything came through pretty smooth... I jailbreaked it after I restored and gamecenter still worked smoothly. Then I restored to my last back-up and opened gamecenter after it all loaded up and everything is still working fine. Hopefully this simple troubleshooting helped out. It did for me.

  • So in essence you are saying that a restore will correct the Game Center loading issue? Might the problem have cleared by just waiting? – bmike Mar 16 '13 at 2:53

happened to me after a normal boot (i have semi-untethered 6.1.3) i just boot tethered and problem solved, game center logged in automatically, without giving my apple id.


I had that just now. Resetting your network settings fixed this.

  • PS. I have an iPhone 4 jailborken device – user59142 Oct 9 '13 at 7:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .