My mp3 in iTunes shows a time of about 20 minutes, when it really have about 5 minutes. The VLC Player and the Windows Media Player shows the correct time for the same file, what's wrong with my iTunes?


The incorrect time is most likely due to an error introduced by the encoding software. You can repair the problem by using the Convert to AAC feature in iTunes.

In iTunes 11 this feature can be found under the Create New Version → option of the File menu.

| improve this answer | |
  • This is apparently no longer a solution in iTunes My song was in MP3, but the file menu had no AAC conversion. Only convert to MP3, which it did, making two MP3 files, both still with the wrong length. Deleting them from the library, closing iTunes, renaming the file, then opening iTunes and re-importing gave it the same wrong length as before. – WGroleau Oct 6 '19 at 6:42

How can I fix incorrect mp3 duration @ askubuntu had a couple of command line solutions.

For me, the ffmepg solution worked (ffmepg can be installed to OS X with Homebrew, for example):

ffmpeg -i file_orig.mp3 -acodec copy file_fixed.mp3
| improve this answer | |
  • This even fixed files that were generated by ffmpeg! – wisbucky Mar 8 at 15:37
  • this worked but holy moly ffmpeg has a ton of cask dependencies! – chandlervdw May 6 at 15:42

Mr. Van Cool's fix did not work. Jaberg's suggestion worked, but I found an easier way to get to the "Convert ..." option. From the songs menu, right click on the songs with the bad time & "Convert to AAC" is in the popup menu. Fixed 4 songs in under a minute, added the M4A files to my playist, and burning to CD worked as expected.

| improve this answer | |

The wrong time duration, is not solved with iTunes 11 and it's not depending from the encoding software (with the new releases of iTunes).

Even re-loading the file, deleting it form the device, often doesn't sovle the problem.

the only one effective solution I found (I got several times this issue) is:

  • Remove the file with iTunes form your device
  • Check if the song was really removed from the device, into the device itself with iTunes on the iPhone or iPad. If not, touch the title, shift your finger to left, and a red rectangle "DELETE" will appear and touch it.
  • Rename the file of the song and re-upload it.

The reason of the 3rd point above is that: I noticed that often, even applying the first 2 points, for some reason (unknown to me), the device still put the old duration and/or old parameters. Changing the original file name, solves the issue.

| improve this answer | |

I had the same problem. My track was more than an hour, but it only showed 1h04mins. Converting to AAC or apple lossless didn't work for me.

Fixed it by using this app called Tag Stripper, https://itunes.apple.com/us/app/tag-stripper/id432262744?mt=12

  1. strip the track of its ID3 tags

  2. import it fresh into iTunes. Track duration should be fixed now

  3. cmd+i to edit the id3 tags.

Done. There might be a simpler way, but this worked for me.

| improve this answer | |

What I did is pull up my editing software and cut out the length that was having the problem, and created a new file. Nothing else worked for me.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .