I'm trying to uninstall Silverlight and install an older version to get Netflix working again.

I updated Silverlight to version 5 not knowing that Netflix would end up throwing a N8109 error. Netflix FixIt recommended uninstalling and reinstalling Silverlight.

Here is what I tried:

  1. Closed all browsers and dragged Silverlight to bin from /Library/internet-plugins

  2. Also cleaned out Silverlight files from /Library/Receipts and /Library/Application Support

  3. Tried using AppCleaner to find and delete Silverlight - Just ended up not being able to find it in any of the categories

  4. Restarted my computer a bunch of times after every uninstall strategy - only in vain

  5. Tried using Spotlight and Finder to find any traces of Silverlight, again to no avail.

Every time I try to install the silverlight.pkg (downloaded using the link Netflix provides while trying to play any video) the wizard detects a newer version of Silverlight on my HardDisk-Mac HD.

The one thing I noticed was that no matter what approach I took, I always found Silverlight app on my Launchpad which again I couldn't delete straight out.

Anybody been able to break through this wall?

  • Have you tried deleting Silverlight.plugin and WPFe.plugin from /Library/Internet Plug-Ins/ as explained here: microsoft.com/getsilverlight/get-started/install/… ?
    – jaume
    Commented Jan 23, 2013 at 10:54
  • Yes I have...Like I mentioned in my question, there is absolutely nothing in any of those key locations Commented Jan 23, 2013 at 13:08
  • Please double check that you have deleted: /Library/Internet Plug-Ins/Silverlight.plugin, /Library/Receipts/Silverlight.pkg, /Library/Receipts/Silverlight_W2_MIX.pkg, /Library/Internet Plug-Ins/WPFe.plugin and /Library/Receipts/WPFe.pkg If that's the case, can you open Terminal (Applications>Utilities>Terminal), run sudo installer -dumplog -verbose -pkg /Volumes/Silverlight/Silverlight.pkg -target / and post the output (change the path to your Silverlight.pkg accordingly)?
    – jaume
    Commented Jan 23, 2013 at 15:45
  • @jaume Alright here is what I got: Jan 25 21:30:18 Brahmis-Mac.local installer[8946] <Debug>: fileURLForURL = x-disc://Silverlight/Silverlight.pkg Jan 25 21:30:18 Brahmis-Mac.local installer[8946] <Debug>: fileURLForURL = file://localhost/Volumes/Silverlight/Silverlight.pkg installer: Cannot install on volume / because it is disabled. installer: A newer version of this software already exists on this disk. Pretty much the same thing I get when I double click and try installing the package through the Wizard. Commented Jan 26, 2013 at 2:32
  • I'd suggest that you reinstall the newest version. Try running the installer. If that fails you might need to open Terminal and use sudo pkgutil -repair Silverlight. Then uninstall it by following the official Microsoft documentation: microsoft.com/getsilverlight/Get-Started/Install/Default.aspx or, failing that, using AppCleaner. Then install the version provided by Netflix.
    – jaume
    Commented Jan 26, 2013 at 13:16

2 Answers 2


I just spent an hour tearing my hair out, just like you. Deleted everything I could find, and still no luck! Fortunately, I found out about pkgutil when trying to research if other apps have similar issues. Run this command:

$ sudo pkgutil --pkgs

If com.microsoft.SilverlightInstaller shows up, it still thinks it is installed. I had to "clean" (kinda) the installation by using the following:

$ sudo pkgutil --repair com.microsoft.SilverlightInstaller

After that, I was then able to cause pkgutil to forget about the installation:

$ sudo pkgutil --forget com.microsoft.SilverlightInstaller

Hope that works for you!

  • Be careful with the spelling, I had to run sudo pkgutil --forget com.microsoft.SilverlightInstaller instead.
    – user74443
    Commented Mar 30, 2014 at 20:12

Silverlight is installed but does not work.

Mozilla blocks older versions of Silverlight, causing sites like Netfix to display a message asking you to install Silverlight. To fix this, please update your installation of Silverlight to the latest version using Microsoft's Silverlight installation page.

In some cases, this may not resolve the problem and you will need to manually activate the Silverlight plugin:

  • On the menu bar, click on the Tools menu, and then click Add-ons. The Add-ons Manager tab will open.
  • In the Add-ons Manager tab, select the Plugins panel. Find Silverlight in the list of plugins and select Always Activate in its drop-down menu.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .