118

I installed Microsoft's Remote Desktop and connected to a PC. How can I share files between my Mac and PC?

When I use RDP on Windows, I can simply add a file to the clipboard and paste it inside the RDP window. The same thing doesn't seem to work in the mac version of RDP.

If I try to share one of my Mac's folders with the RDP computer, and then double click that drive in RDP it says:

\\tsclient\Downlo1 is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.

Access is denied.

  • Can you browse \\tsclient ? – Harv Feb 8 '11 at 2:30
  • @Harv: yes, it shows me a single folder, \\tsclient\Downlo1, which when I try to access, gives the same error message. – Senseful Feb 8 '11 at 3:07
  • sounds like a permissions error, not RDP. Are you on the same LAN? It looks like RDP is trying to access the target windows box using SMB, which is a whole ordeal in and of itself. – Fake Name Feb 9 '11 at 6:57
  • @Dori: won't the tag [remote-desktop] be very confusing since both Apple and Microsoft have products named "Remote Desktop"? – Senseful Feb 10 '11 at 8:14
  • there are good reasons on both sides; my own opinion is that, given that less than 1% of this site's questions are on any "Remote Desktop", there's no real need to split them. – Dori Feb 11 '11 at 0:08
148

When copying files from Mac to PC using Microsoft Remote Desktop I prefer to share a subfolder, not the entire drive.

Here's how:

  • In Remote Desktop on your Mac select your PC in the "My Desktops" section.

  • Click the "Edit" button (pencil icon).

  • In the popup click the "Redirection" button (folder icon; see image below).

  • Check the "Enable folder redirection" box.

  • Click the "+" button at the bottom of that window and browse to the Mac folder you want to share.

  • Connect to the remote PC.

  • Look for your shared Mac folder in your PC's "My Computer" directory (see image below).

enter image description here enter image description here

Finally, as noted by @Bart and @robbpriestley in the comments below, if you are already connected to the remote computer you need to re-establish your connection in order to see the shared folder.

  • Thanks for sharing the new method of establishing the link. It confused me at first since the option mentioned by previous posters is not available, but I figured it out -- before reading your post... ;) – Evan Stone Nov 7 '14 at 19:41
  • 1
    Definitely better than sharing your hard drive – DagW Apr 24 '15 at 9:18
  • 3
    Great! The only thing which had me stumped was that I didn't see my folder immediately under 'Computer' of the remote after I had added the 'redirection' folder on local. I figured out I had to restart the remote desktop connection first, because I had already been connected whille adding redirection. So step 5 can also be read as 'Connect to the remote PC (or reconnect if you had already been connected)'. – Bart Oct 22 '15 at 11:36
  • It seems that Microsoft Remote Desktop can't handle paths that contain spaces. I tried hard to share a folder with such a path – no luck. Then I created and shared a folder on my desktop, and it showed up immediately when I reconnected to the remote PC. – Rolf Staflin Sep 27 '16 at 15:32
  • I'd recommend editing the answer and adding that if you are already connected to the remote computer that you need to re-establish your connection in order for the shared folder to appear. I spent quite a few minutes until I read @Bart comment above. – robbpriestley Sep 20 '17 at 22:45
17

Troubleshooting steps for the inability to copy between a Mac and PC - http://mac2.microsoft.com/help/office/14/en-us/rdc/item/2aae839c-7f91-4738-aea7-9ffb25dbfe2e?category=ff488916-8b5e-4a0c-af96-37d065645612.

I think this answer will likely fix it:

Solution: Before you start the Remote Desktop session, make the Mac disks available to the Windows-based computer.

1.On the RDC menu, click Preferences.

2.Click Drives, and then on the pop-up menu, select the option that you want.

Your disk or folder is now available so that you can access files that are on your Mac from the Windows-based computer.

If you make this change after you connect, the disk or folder that you select becomes available the next time that you connect.

3.On the Start menu, click Computer or My Computer.

The Mac disk or folder that you have made available is listed with all other disks and folders on your Windows-based computer.

Note If you can't see the Start menu, on the View menu, click Full Screen.To return to window mode later, point to the top edge of the screen until the RDC menu bar appears. On the menu bar, click View, and then clear the Full Screen check box.

4.Open the disk or folder that you want to copy from.

5.On the Start menu, click Computer or My Computer.

6.Open the disk or folder that you want to copy to.

You should now have two windows open, one for the location that you want to copy from, and one for the location that you want to copy to.

7.Drag the document that you want to copy to the location that you want.

  • This fails at step 4, which doesn't let me access the Mac's contents with the error message I posted above. – Senseful Feb 10 '11 at 4:42
  • 1
    This isn't an ideal situation, as that connection is a two-way street. Anyone on the remote machine can access your local files. – kristina childs Feb 6 '13 at 18:48
4

Clipboard RDC is a free open source cross platform utility that uses clipboard to transfer files much like we transfer text to/from servers in RDP.

Note, requires Java.

Disclaimer: I am the author

  • 1
    My plan B was going to be something like this. – boulder_ruby Jan 20 '14 at 19:26
3

Another possibility is to use a dropbox (et.al.) account. Just log into the same one from both the Mac and the PC.

  • 1
    There are some organizations that block Dropbox, or in my case, I just really didn't want to use it on my work machine, since who knows what they're snooping... However, this is a GREAT suggestion for anyone who doesn't have those concerns (or who doesn't work in a highly/strictly-regulated corporate environment). Well done. – Evan Stone Nov 7 '14 at 19:38
2

I ran into the same issue but I was able to paste to \\tsclient\OSX\Users\Shared

  • I too was able to map a folder in /Users/Shared whereas anything in /Users/<me> failed due to permissions. – Josh Nov 6 '12 at 10:46
0

Your shared folder has a name that is too long. Try calling the share "foo," connecting to terminal services, and then accessing \\tsclient\foo.

  • I tried doing this, but it gives the same error message. – Senseful Feb 9 '11 at 19:21
  • Are you sure you're changing the share name? Access Network, and see that the share name is indeed foo. – Harv Feb 9 '11 at 21:37
0

I will second the Dropbox recommendation. This is the single greatest way to keep many different machines in sync with files there is. If you save a file on your Mac, within seconds it seems, the same file is updated on your PC.

A second approach is to use LogMeIn Pro which can do this but it costs money. In my experience, the speed of LogMeIn is much faster than RDP for remotely controlling another machine.

0

If you right-click on the folder on your Mac and then "Get Info", what permissions do you see?

Make sure your username (the user that initiated the RDC session) has read and write access to the folder. If that doesn't work, give "read & write" to "everyone" (be careful with this one - anyone with access to this folder will be able to modify the contents).

-2

Try copy pasting the whole folder. It is easy and quite flexible at the same time It worked like a charm for me.

cmd C (on Mac)

ctrl V (on Windows)

  • Welcome to Ask Different. The OP stated that simply pasting from a Mac isn't working for them (it works from a PC). Please see How to Answer for tips on providing quality answers and avoiding downvotes. – fsb Sep 25 at 13:10
  • @fsb but it is working on my Mac OS High Sierra – Tech guy Sep 25 at 16:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .