The USB ports on my MacBoook Pro13 stop working after a while (new devices aren't recognized by the OS, already plugged in devices don't work any longer, the behavior is the same for all USB devices and both USB ports). Doing a restart fixes the problems for a while (about a day of use). The way I'm usually working, the Mac goes to sleep a few times during the time it works. I've tried the standard procedures of resetting PRAM and repairing disc permissions without success.

I'm not sure how long I've been having this problem, it might be related to updating to Mountain Lion or some version change in VMWare Fusion (and no, the USB hardware is not available there, either). As the problem is not occurring directly after a reboot, I'm assuming it is not Hardware-related. Still I'd like to avoid a complete re-install.

What can I do to further diagnose and fix the problem?

UPDATE: Thanks for the suggestions. I wasn't able to try all of them .. interestingly, my USB has been working for more than a week now, and I'm not sure what changed. (Maybe I'm using VMWare in a different way, maybe it has to do with the way I use my MacBook.) So I haven't been able to verify that any of the changes solve my problem (which makes awarding the bounty a bit tricky). I'll update the question when I have new information - but hopefully my USB continues to work!

  • From your problem description, it seems it may be related to the sleeping of your computer. Could you confirm this? Hint: in a Terminal type grep -i PM /var/log/system.log.
    – dan
    Jan 25, 2013 at 7:06
  • I ran it and got a number of "hibernate write took .." messages. A few errors from CrashPlan, but no USB-related errors - but the error has not occured so far since rebooting. I'll keep observing it .. what would I be looking for?
    – IronGoofy
    Jan 25, 2013 at 18:06
  • You should be looking backward starting from the time when you detected your USB was off. And look if you see any "closely related" event as a "wake", "kext"…
    – dan
    Jan 26, 2013 at 9:57
  • Could you indicate completely what is connected to your MBP set of USB ports?
    – dan
    Jan 26, 2013 at 9:59
  • 2
    @IronGoofy Download from developer.apple.com/downloads/index.action a package to log IOUSBFamily behavior. Just put USB at search field, a free developer account is required.
    – Shane Hsu
    Jan 30, 2013 at 10:49

4 Answers 4


The first step in diagnosing the problem is to create a user account and see if it happens for that user. If it still happens, it's probably hardware but could still be software. To verify it is not, then remove any software that installs Kernel extensions (VMWare does this, as well as USBOverdrive, SteerMouse, etc…) and see if it still happens.

The fastest route is probably taking it to the genius bar, even if the machine is out of warranty. They have tools that aren't released to the public that go much deeper than any commercially available hardware diagnostics software.

  • I'm ready to bet that the test with another account will exhibit the same USB deafness. This is a good 1st check to run anyway.
    – dan
    Jan 26, 2013 at 10:03
  • If a new account shows the same behavior then it's either a bad kernel extension, like an outdated USB Overdrive or Steer mouse driver (those are two excellent third party mouse drivers) or it is hardware. If no third party kernel extensions have been installed then its got to be hardware.
    – Ɱark Ƭ
    Jan 26, 2013 at 13:04
  • It was a bit tricky to test with a new account (don't know how to reproduce ;-)), but the problems occurs there as well.
    – IronGoofy
    Jan 26, 2013 at 21:23
  • I think you need to make an appointment with an Apple Genius.
    – Ɱark Ƭ
    Jan 26, 2013 at 21:30
  • @IronGoofy: How much time had you to wait between a boot and the USB going deaf? Did you use VMware Fusion? Did you notice any change in the list of USB Kernel extensions loaded?
    – dan
    Jan 26, 2013 at 21:37

I advise you to check for any USB misbehaviour.

All the hereunder commands will have to be run from a Terminal or an xterm window.

  1. Log analysis:

    grep USB /var/log/kernel.log

    look for events closely related in time with your USB hub getting deaf.

  2. Deeper USB behaviour analysis. 1st create a working directory:

    mkdir ~/USB.bug
  3. When your system freshly started, run the following command:

    kextstat | grep USB >~/USB.bug/kext.start

    This will be a reference to compare your living Kernel behaviour to later.

  4. Next, after having used all your usual softwares having any relation with your USB connection, do a first check:

    kextstat | grep USB >~/USB.bug/kext.run
  5. Finally, when your USB port is deaf, type:

    kextstat | grep USB >~/USB.bug/kext.bad
  6. Compare:

    cd ~/USB.bug
    diff kext.start kext.run
    diff kext.run kext.bad

    Please include results of this hunt start.

  • Please include the results of these difference analysis tricks. From what you got there it's is possible to target a search toward a power managment problem, an USB driver problem or an internal USB hub problem.
    – dan
    Jan 28, 2013 at 22:31
  • All this really will do is show the user the same thing he sees in the way the hardware performs. This is not needed. Adhere to the KISS philosophy. It's Apple's mindset, and should be the users. (kiss = keep it simple stupid) Jan 29, 2013 at 21:16
  • I adhere to this KISS religion too, but with a very clear guardrail. This limit is the point where you make users fall full stupid. This a no return point. You won't improve reputation or selling with a population of users lead to fall in deep stupidity. "Reinstall the OS" is one of the mantra of this kiss religion. I don't trust this one :[.
    – dan
    Jan 31, 2013 at 20:24
  • Daniel, While I agree with you, asking someone who's skills within the Unix environment are unknown, to mess around in terminal often times does more negative than positive. There was nothing in his original post to show that he had that skillset, which is why I err on the side of caution in my response. Jan 31, 2013 at 21:51
  • Also, my reinstall option isn't an erase and install. Just an installation over the existing files. Jan 31, 2013 at 21:52

There are two reasons this is happening.

Hardware and Software.

Your first solution would to be to run the installer again, and see if that fixes the issue. Make a backup of your data first just in case.

If that does not work, then you will need to do a clean install of the OS.

If that does not work, you have a failure in the hardware and will need to have that repaired by an ACMT. 90% of these terminal commands are just checking for stuff youc an already see by the USD losing connectivity. They are just affirming that. Good luck.

  • Which installer? As noted, USB goes away completely, not just one device.
    – IronGoofy
    Jan 30, 2013 at 10:30
  • OS installer. The fact that it comes BACK leads to the potential for software. try that FIRST, then look at hardware Jan 30, 2013 at 19:49

I had this experience on a Mac Book Pro. Unfortunately, none of the software fixes worked. A trip to an Apple repair center showed that the problem was the on the motherboard.

I did not want to have to buy another machine, or pay a ton to replace the motherboard. So I bought an add-on card that had a USB port. I don't know if your system has this kind of capability, but this device at OWC is quite reasonable.

  • Are there MacBooks that still have an ExpressCard slot? Mine "only" has an SD card slot ...
    – IronGoofy
    Jan 30, 2013 at 10:33
  • See how old I am. Anyway, another solution is a firewire to USB adapter. Here's a bunch at Amazon: tinyurl.com/9wtdb49
    – ICL1901
    Jan 30, 2013 at 14:12
  • This might be a "workaround" .. but only if the problem is hardware-related (as in your example). For now I'm not sure what is causing my problems. Maybe I should see if a visit to the Genius Bar turns up anything useful.
    – IronGoofy
    Feb 1, 2013 at 20:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .