My laptop goes to sleep and when I open the lid it wakes up just fine (or I move the mouse if I didn't close the lid).

Now sometimes when I open the lid, it doesn't wake up. The status light which is usually going on/off is just not lighting up at all when the lid is open. If I close the lid again, then the light remains lit but doesn't toggle on/off.

The only way I can get things to work is if I press the power button for like 10 seconds to force it to shutdown.

What is happening here?

Note: I press fn-control and the eject key to put into sleep mode (to avoid it going into the clam shell mode).

The output of pmset -g is:

Active Profiles:
Battery Power -1
AC Power -1*
Currently in use:
 womp 1
 halfdim 1
 sms 1
 hibernatefile /var/vm/sleepimage
 gpuswitch 2
 networkoversleep 0
 disksleep 10
 sleep 10
 hibernatemode 3
 ttyskeepawake 1
 displaysleep 10
 acwake 0
 lidwake 1 
  • Can you provide the output of 'pmset -g' when entered in Terminal?
    – Adrian B
    Feb 12, 2013 at 8:54
  • 1
    Do PRAM and SMC reset, you can find Apple Docs for these.
    – Shane Hsu
    Feb 12, 2013 at 17:05
  • @AdrianBurgess Active Profiles: Battery Power -1 AC Power -1* Currently in use: womp 1 halfdim 1 sms 1 hibernatefile /var/vm/sleepimage gpuswitch 2 networkoversleep 0 disksleep 10 sleep 10 hibernatemode 3 ttyskeepawake 1 displaysleep 10 acwake 0 lidwake 1
    – Blankman
    Feb 13, 2013 at 1:09
  • 1
    Before you sleep the Mac, prepare to run sysdiagnose; then when the problem occurs, use the key chord for sysdiagnose. See apple.stackexchange.com/a/58595/8546 Feb 14, 2013 at 19:27
  • Have you tried changing the "deepsleep" option to no deepsleep -- sudo pmset -a hibernatemode 0 Feb 18, 2013 at 17:57

5 Answers 5


I’m new here, but old hat when it comes to troubleshooting Macs.

Sounds like the computer isn’t going to sleep consistently. Often this happens if there’s something running on the computer preventing it from sleeping.

These are the steps I usually take, for this kind of thing, with the more common, easier steps first. If you find something during one of these steps, take the action to resolve it, then test the sleep functionality.

  1. Check for updates. It may sound awfully trite, but Apple does release firmware updates from time to time, often addressing issues relating to the System Management Controller (SMC), which has everything to do with this kind of issue.

    Third-party software also plays a big role when it comes to software problems, so check for updates for all of these as well. (Most third-party software allows you to check for updates within the application.)

  2. Check for any errant, unfinished print jobs. I’ve frequently seen this be the cause. You can do this by opening System Preferences > Print & Scan (or similarly named).

    If you see a printer that says “In Use,” and you’re not trying to print something right now, then that’s a good clue this is your problem. From here, you can delete the troubled job (Apple Support article PH10608).

  3. Check Activity Monitor (it’s in the Utilities folder) to see what’s currently running. Be sure to choose “All Processes” from the pop-up menu.

    Backup software (like WD SmartWare), online syncing software (Dropbox, CrashPlan, Carbonite, etc.), out-of-date anti-virus or security software, auto-updaters and some third-party utilities can all prevent the computer from sleeping, especially if they’re in the middle of a task. Try disabling or turning them off from within its application or menu in the menu bar (and check updates for these, too).

  4. Check how much hard drive space you have available. You’d probably have other symptoms, but it doesn’t hurt to check. Activity Monitor will tell you (click “Disk Activity” and look for the pie chart), or in OS X 10.7 Lion or later, Choose  > About this Mac, then “More Info…” and “Storage.”

    It varies by version, and what you’re actively using on the computer but if you have under 10 GB hard disk space free then it’s time to empty the Trash.(Apple Support article PH10628) (Tools like DaisyDisk, WhatSize, and OmniDiskSweeper (this one is free) are great help for this. And keep in mind these may only report sizes for the currently logged-in user account.)

  5. Check the file system using Disk Utility (also in the Utilities folder). When your computer goes to sleep, it saves the current state of the computer to a sleep image in /var/vm. If the computer has filesystem or hard disk issues, it may not be able to finish saving the data.

    Choose your hard disk, then click “Verify Disk.” If any errors are found, you can repair them from the Recovery disk.

  6. Check Console for disk errors (where else? Yep, in the Utilities folder). Usually you’d be noticing slowdown issues, but perhaps not if the drive is only just beginning to show trouble.

    With “All Messages” showing, in the search box, type disk i/o. It’s possible to go further back in time through system.log and kernel.log. If you see repeated errors with disk0s2, that’s going to be your boot volume, which ordinarily will be your internal hard drive. You have a failing hard drive.

  7. Check for any connected peripherals. USB and Bluetooth devices, like hard drives or audio interfaces can prevent computers from going to sleep. Disconnect these things and test it out.

  8. Reset the SMC. Though hardly ever needed, it’s a simple and quick step that can easily fix power-related issues.

  9. Try from Safe Mode. (Learn how to Safe Boot: Apple Support article HT1455.) This allows you to test without any auto-launching third-party software and non-essential items, and rebuilds your boot cache, too. (If it works flawlessly, restart and check Activity Monitor again for any constantly running processes.)

After that I suspect I’d backup and try re-installing OS X. And after that, I’d install a fresh copy of OS X onto a second partition of the internal hard drive, or onto an external drive (or erase the hard drive and install if you can afford it) and test. Should you narrow it down to this, try then installing your most essential software one at a time, testing after each item, until you find the culprit.

If after an erase and install you’re still encountering a problem, it’s probably a hardware issue, meaning you’ll need to take it in for repair.


the light on you Macbook indicates that your hard drive is "sleeping" thats why ssd macs don't have the light, so, in order to rule out the possibility of a faulting HDD and software I'm gonna recommend you the easiest and most conclusive way!

install mac os x on a USB tumb drive and run your os from the USB, its gonna be slow, sure however, you are able to rule out software and HDD issues, if it your issue persists, its hardware, that could mean anything between motherboard, graphics (i had this), and ram!

but lets not not jump the gun, just give the usb a try and we can take it from there :)


Have you tried booting up in Safe Mode, logging in, closing the lid to put it to sleep, and reopening to (hopefully) waken it? What happens?

  • it doesn't happen all the time, just now and then.
    – Blankman
    Feb 13, 2013 at 1:02

Odd question: You dont have anything magnetic in the desk you keep it on right? This was driving me mad a few months ago when I realized I had a magnet in my desk drawer that was tripping the clamshell sleep trigger.


It looks like a case of this: https://discussions.apple.com/message/20163244?ac_cid=tw123456#20163244

There is no cure for now, except make sure that you wake the Mac by activating the mouse/trackpad or using the power button. If you unplug a USB device while the Mac is asleep for instance, or have it wake on network activity, it'll get stuck.

Sure feels like voodoo, a very un-Mac-like experience

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .