I own a NAS (a D-Link DNS 320, to be more specific) which has two hard drives and multiple network shares. I can connect to these network shares using the AFP or the SMB protocol.

When I want to connect to a share on drive #1 with Finder, everything works okay. But if I want to connect to a share on drive #2, it starts connecting but does not come to an end (the window "connecting to server" stays open and the progressbar keeps spinning). I tried both smb and afp. If I abort the process of connecting, Finder freezes and I cannot restart it, even with some "brutal" methods. It seems that some mounting points get damaged: If I use terminal or Forklift after aborting the process, they crash when browsing to "/mnt/Volumes".

The reason I ask you on apple.sx for help is that both drives work well via smb on my android phone or my windows machine.

I already tried:

  • Create a new user account and connect from there: same problem (so it is not the .GlobalPreferences.plist-problem)
  • Mount from Terminal: the "mount" command gets stuck
  • Disable TimeMachine and remove TimeMachine shares (TimeMachine had some problems with my NAS in the past)

I use Mountain Lion 10.8.2 on a MBP late 2011. Thank you for your help.

  • Look through the logs with Console.app to see what is happening during the connection to drive #2. Jan 19, 2013 at 12:15
  • @BartArondson: There is no log written to the Console before / while connecting to the drive... There some are messages from successful connections to other shares, but for that drive there is just nothing. Jan 19, 2013 at 14:48
  • Are you connected to a VPN at the moment of the connection? this happens to me when I am.
    – Pedro
    Aug 28, 2017 at 21:21


You must log in to answer this question.

Browse other questions tagged .