I had Apache working on my 10.8 MPBR. I haven't used it for a few weeks, and now it doesn't seem to start. I get nothing in /private/var/log/apache2. Nothing, meaning no logging at all, error or otherwise. Permission on the log folder is drwxr-xr-x root wheel

I have tried all ways of starting, stopping, and restarting apache. I have checked for activity on port 80, there is nothing happening.

Configtest is Syntax OK. I have not fiddled with apache in any way in the time between now and when it was last working.

I do get a 'weird reason' error in the console.

1/17/13 8:47:34.592 PM com.apple.launchd[1]: (org.apache.httpd) Throttling respawn: Will start in 10 seconds
1/17/13 8:47:44.594 PM com.apple.launchd[1]: (org.apache.httpd[22855]) Job failed to exec(3). Setting up event to tell us when to try again: 2: No such file or directory
1/17/13 8:47:44.594 PM com.apple.launchd[1]: (org.apache.httpd[22855]) Job failed to exec(3) for weird reason: 2
1/17/13 8:47:44.594 PM com.apple.launchd[1]: (org.apache.httpd) Job should be able to exec(3) now.

The 'No such file or directory' bit is suspicious, but don't know what file/dir is missing. My next move will be to try and start from a plain vanilla setup and see if that works.

I'd rather not install MAMP, I only need the web server, so hopefully I can figure out what got borked.

Anyone know how to get better debugging on what the Console is on about?

Anyone care to guess what might have gotten out of whack?

  • Did you try "sudo apachectl graceful" to restart?
    – soxman
    Commented Jan 18, 2013 at 21:30
  • 1
    Show us the end of the /var/log/apache2/error_log please?
    – maksimov
    Commented Jan 19, 2013 at 1:13
  • As mentioned above "I get nothing in /private/var/log/apache2". I mean nothing, like no output of any kind.
    – tehfoo
    Commented Jan 22, 2013 at 20:26
  • @soxman no form of starting, stopping, or restarting helps. Apache seems to not respond in any way. Edited above to reflect this.
    – tehfoo
    Commented Jan 22, 2013 at 20:27
  • Edited above to add more detail, some in response to questions
    – tehfoo
    Commented Jan 22, 2013 at 20:34

5 Answers 5


I had exactly the same problem. I started Apache without DocumentRoot(s). It did the trick.

sudo apachectl -T
  • That first gave me an error/warning httpd: Could not reliably determine the server's fully qualified domain name, using sinisterkid.local for ServerName. I think setting ServerName in the httpd.conf file will fix that. Now Apache seems to be running... but won't stop.
    – tehfoo
    Commented Feb 21, 2013 at 23:52
  • About my case, I realize that I completely forgot about web sharing on mountain Lion. I installed this plugin : clickontyler.com/blog/2012/02/web-sharing-mountain-lion but It was off...
    – clempat
    Commented Feb 28, 2013 at 13:14
  • Check as well this : blog.joshdick.net/2012/07/28/… and try sudo apachectl -k start
    – clempat
    Commented Feb 28, 2013 at 14:34
  • I'm accepting the -T answer, but I'm not convinced that's what actually got it working again. When I tried -T the server started, and I couldn't shut it down again no matter what, apache kept respawing processes no matter what I did. I did a reboot with the launch daemon loaded and now it seems to be working fine. So weird.
    – tehfoo
    Commented Mar 7, 2013 at 18:54
  • Wow, it didn't have to be this simple. It worked. Wonder, why apachectl did not throw permission error.
    – anwerj
    Commented Aug 5, 2020 at 14:13

I've seen similar just today, no logs and apache acted like it was started. The issue for me was a bad vhost file.

sudo apachectl -S this allowed me to see the error

  • This does not really answer the question. If you have sufficient reputation, you may upvote the question. Alternatively, "star" it as a favourite and you will be notified of any new answers. If you have a different question, you can ask it by clicking Ask Question with a link to this question if it helps provide context.
    – grg
    Commented Feb 13, 2014 at 17:55

I've had similar issue with apache and I found our what was wrong (and in which config file) with this command:

sudo apachectl configtest

I found out about this from this forum post about apache issues.


The logs are by default in /var/log/apache2/ and not in /private/... if you haven´t changed it you can also use Launchpad=>Utilities=>Console to look in it.

  • 2
    /var/ is a symlink to /private/var/.
    – Lri
    Commented Jan 19, 2013 at 1:46
  • Yes, you are right, that it is a symlink ... but the world could be less complicated to open the console app (why we should not use it if it is already there) and look in /var/log instead to make a expedition through /private/var/log/apache2/ to look in some apache logs. Commented Jan 19, 2013 at 9:42

Have you installed/upgraded ruby? check out your org.apache.httpd.plist , see if you got http-wrapper there. if so it may be issue with ruby binary. check your paths and soft links again.

  • Why would Ruby be the cause of apache not starting?
    – Lætitia
    Commented Mar 15, 2013 at 2:05
  • Because Apache on 10.8 is started by httpd-wrapper, a ruby script. According to this StackOverflow post, replacing your system ruby version can cause issues with it.
    – Eric3
    Commented Apr 26, 2013 at 2:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .