4

In OSX 10.8.2, I created a service using Automator and saved it in ~/Library/Services. The service receives selected messages in Mail.app. It shows up in the list of services when I click on the "Mail" menu. When I click on the service, it executes correctly. It also shows up in the list of services when I try to assign a keyboard shortcut to it in System Preferences. My keyboard shortcut doesn't appear to conflict with any other. To make sure of this I've tried assigning very improbable shortcuts involving 4 or 5 keys.

Somehow the shortcut never "registers", i.e., it doesn't appear next to the service name in the "Services" submenu of "Mail" and using the shortcut doesn't produce any result. What could be causing this?

  • Have you tried logging out and back in? There's a bug on 10.7 and 10.8 where the shortcuts for Automator services don't always work until the services menu has been shown from the menu bar (by for example hovering over Mail > Services), but I'm not sure if this is related to it. – Lri Jan 18 '13 at 18:54
  • Logging out and back in doesn't seem to resolve the issue. Still no shortcut appearing next to my service in Mail > Services and the shortcut still has no effect. – Dominique Jan 18 '13 at 21:06
  • This is still an issue in 10.10.5 – supergra Mar 2 '16 at 18:13
1

One possible reason is that your user account has lost rights to change services preferences file (some buggy installers can cause that). Open Terminal and type

ls -la ~/Library/Preferences/pbs.plist

If you see that the owner is root, that is the problem:

-rw-------    1 root  wheel    1407 Jan 16 13:40 /Users/me/Library/Preferences/pbs.plist
                  ↑
                 incorrect!

In that case, you can fix the problem by typing this command (replace me with your user name; you will be asked for your password):

sudo chown me:staff ~/Library/Preferences/pbs.plist
  • Is the file writable (has w in -rw-------)? You can also try to run "Repair Disk Permissions" via Disk Utility for the whole startup disk. – hamstergene Nov 21 '14 at 6:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .