I just bought a new Pioneer XW-SMA3 AirPlay speaker system but have so-far been unable to connect it to my home WiFi Network. The speakers come with an Ethernet port so I am able to connect it via that and configure it, but nothing I do will connect it to the wireless.

My home network is served up from an Apple Airport Extreme (bought at the end of 2011) secured via WPA2 Personal (all my other devices connect to this just fine including the Wii, iPhones, friends' windows boxes etc) as per the following screen snap (SSID obscured): Airport Extreme Wireless Setup

When I configure the speakers I am given the following security options: Speaker's wifi security options

However when I choose WPA2-PSK(AES) (which I am told is the equivalent to Apple's WPA2 Personal and reboot, the speakers still don't connect and when I reconnect via Ethernet the config shows me that it's selected WPA-PSK(AES) instead. See: Speaker Config

I've tried dumbing my network security down to WPA/WPA2 Personal but that made no difference, and I've also tried selecting the WPA2-PSK(TKIP) option in the speakers' config but when it reboots it shows as WPA-PSK(TKIP) instead, analogous to the AES setting.

I have also tried updating the speakers' firmware to the latest version just to be sure but it made no difference.

I've triple checked the obvious things like the SSID name and the password.

I lodged a technical support request with Pioneer but got no answer, and so today I phoned them and they told me that “We are not networking specialists. We can't help you.” which is utterly useless. I am hoping someone here has succeeded in connecting these speakers to their WiFi. Googling the problem gives me no sensible results.

4 Answers 4


My speakers are now on my wifi. A bloke called Jason from Pioneer called me this morning and told me to ignore the manual and instead to do the following:

  1. Turn the unit off and unplug it from Ethernet and power.
  2. Plug the power back in and turn the unit back on — wait for it to power up again.
  3. Plug your iOS device (assumes you have one, and that it is currently connected to your wifi) into the USB port in the back of the speakers and unlock the iOS device so that it shows the home screen.
  4. Press and hold the Input button at the front right of the speakers, along with the hidden little black button on the back labelled • Network Setup / - wireless direct, and keep both held down for about 3 seconds.
  5. A dialog box will appear on your iOS device saying "A connected device wants to share your network settings (cancel) or (allow)."
  6. Press (allow).
  7. Wait about 10 seconds and open the Music app on your iOS device and click on the AirPlay icon. Your speakers will appear in the list of available speakers.
  8. You can now unplug your iOS device as the speakers are connected to your wifi.

I actually had to try this process twice to get it to work but now it's working perfectly. In Safari on your Mac under the Bonjour menu in Bookmarks your speaker will appear and you can then perform any other configuration you like, such as giving the speakers a more sensible name.

  • 1
    I ran into the same problem, however setting it via iOS didn't work for me. Whether I use that method or configure via Setup Mode, when it restarts it always goes back to "Direct Connect" mode and can't be taken out of it. SUPER frustrating. I'm on the verge of giving up on this thing.
    – user56639
    Sep 7, 2013 at 20:09
  • Try connecting to it from Ethernet and upgrading the firmware. Then try the iOS connection.
    – Dave Sag
    Sep 8, 2013 at 0:07
  • @Tara Just FYI I upgraded the firmware on my speakers today and that resets it to it's original factory settings. I followed my instructions and it worked perfectly.
    – Dave Sag
    Sep 21, 2013 at 3:03
  • Looks like this behavior depends on firmware pioneerelectronics.com/ephox/StaticFiles/PUSA/Files/SMA1_3_4/… I was able to connect to the wifi with Ver s1051.1000.0 but I can't do this anymore with Ver s1080.1000.0
    – A B
    May 2, 2015 at 20:00
  • Also this iOS connection works only with older iPhones like 3GS. Iphone 6plus ignoring this command
    – A B
    May 2, 2015 at 20:02

It might be worth sniffing the air with something like Kismac http://kismac-ng.org/ so see what is going on with the SSID you are trying to connect to, and also see what the speakers think they are doing.

  • Awesome, I'll give that a try and report back.
    – Dave Sag
    Jan 17, 2013 at 2:57
  • Alas KisMac doesn't work on 10.8 (or 10.7 either).
    – Dave Sag
    Jan 17, 2013 at 3:03
  • Interesting. Used pimley.net/projects/#airlock which shows my network is running on channel 149 which seems a little high. Will dig deeper
    – Dave Sag
    Jan 17, 2013 at 3:08
  • Also looking at wireshark.org/download.html
    – Dave Sag
    Jan 17, 2013 at 3:09
  • sigh - wireshark need x11 which I don't have, or want.
    – Dave Sag
    Jan 17, 2013 at 3:10

Alternatively set up another Access Point (AP) in the same address range as your network and see if it will connect to that AP, surely you have a few APs laying around.

Try asking in one of the Community Wireless Groups like http://www.air-stream.org, there might be a community wireless ground in Canberra that can help you out.

  • The forums there are for paying members only but I'll consider joining as it looks like a good community.
    – Dave Sag
    Jan 17, 2013 at 2:59
  • Please don't post multiple answers, this is not a forum. Edit your existing answer to add additional information. I would also suggest you read the FAQ and the about pages. Jan 17, 2013 at 6:11

Pioneer wireless speaker might be incompatible with your router. Try to disable N(5gHz) network

  • Thanks but this question was answered a while ago (see my answer above)
    – Dave Sag
    Jul 21, 2014 at 4:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .