I have a 2008 Macbook Pro running OS X 10.8 on a 500GB (upgraded from original) 1-2 year old hard drive. The drive was encrypted with FileVault2, and the system was running fine a few months ago until one day I believe the power may have been cut or the system crashed and had to be forcefully shut down; I can't remember. Anyway, upon trying to re-boot the system, I would be prompted for my password and, upon entering it, the system would try to boot. The Apple logo would appear and a dark grey progress bar would appear beneath it. After the progress bar got around 1/4 of the way through, the system would shut down.

I left the machine unused for a few months but am now trying to recover any data I can from it. The steps I've taken so far to try and repair or recover the system are as follows;

1) Tried booting into safe or single user mode; system crashes. 2) I can boot into repair mode (command + R), and the drive is shown with the main volume locked. 3) I could unlock the volume using disk utility, and I had the option to verify permission and verify the disk. When verifying the disk, I get an error saying to run repair; however, repair is greyed out and I haven't had the option to run it at any point. 4) Upon following instructions elsewhere, I ran the diskutil revert command, and the status of the primary volume "Conversion Status" changed to "Converting". Since then, I haven't made any other progress. It seems to be stuck, and the system has been running for 2 days with no change (except when it falls asleep and I have to wake it back up)

Here is a summary of what I see when I run diskutil list:

>Logical Volume Group WWWWWWWW
>Name: Mac
>Size: 500GB
>Free space: 16.8MB
>>Physical Volume XXXXXXXX
>>Index: 0
>>Disk: disk0a2
>>Status: Online
>>Size: 500GB
>>Logical Volume Family YYYYYYYY
>>Encryption Status: Unlocked
>>Encryption Type: None
>>Conversion Status: Converting
>>Conversion Direction: backward
>>Has Encrypted Extents: Yes
>>Fully Secure: No
>>Passphrase Required: No
>>>>Logical Volume ZZZZZZZZ
>>>>Disk: disk2
>>>>Status: Online
>>>>Size (Total): 500GB
>>>>Size (Converted): -none-
>>>>Revertible: Yes (no decryption required)
>>>>LV Name: Mac
>>>>Volume Name: Mac
>>>>Content Hint: Apple_HFS

When I reboot, I find that it still asks for my passphrase and still shuts down when that grey progress bar appears. I have put this computer into target disk mode and booted an older mac (running 10.4) which sees the drive but cannot access it or do anything with it. Is there anything else I can do to try and force decrypt the drive or perform any kind of repair to at least have the data become readable, if not allow the system to become bootable again? Please let me know if you need any further information or details. I substituted the UUIDs above for convenience. Thank you in advance for any suggestions you can provide.

  • Ideas: Try target disk mode using a mac that supports Filevault 2 (Lion/Mountain Lion), take it to an Apple store. – Chris A Jan 17 '13 at 17:34
  • Thanks for the suggestions. Some good news and some bad; Good news is that I was able to reinstall OS X onto an external hard drive, boot from that, and recover the data from my internal drive (the one with the problem). I then reformatted the internal drive and reinstalled OS X onto it. This worked fine for about an hour or so as I installed updates and a few applications; but then, some weird things stopped working; For example, I was adjusting settings under System Preferences, and when I went to the Security and Privacy page, I got an error about these settings only being available on... – splintered Jan 20 '13 at 1:32
  • ...an intel-based mac. I am running a 2008 MBP with an Intel Core 2 Duo so obviously something was wrong. The system wasn't responding correctly to other things too, so I rebooted normally and... upon entering my disk password, the same thing as before happened (albeit a bit faster this time) - grey screen with Apple logo, then grey progress bar went through about 1/8 of the way, then the system shut down. – splintered Jan 20 '13 at 1:33
  • I took out the drive and ran SeaTools on it (it is a Seagate refurbished drive) and all their diagnostics passed. The mainboard in the laptop is only a year or two old as well, as it was replaced for free by Apple due to a certain video card issue that was common in this model. I suspected bad RAM, but I've been running memtest all day and it has found no faults. I'm at a loss now as to why this issue would re-occur so quickly. Any other suggestions? – splintered Jan 20 '13 at 1:33
  • Definitely sounds like a hardware issue at this point. I'm out of ideas, sorry. – Chris A Jan 21 '13 at 4:42

You must log in to answer this question.

Browse other questions tagged .