0

When the keyboard is active on my iPhone 4S (running jailbroken iOS 5.1.1 / 6.1.1), there is a key between the space bar and the numeric entry toggle. This key has a microphone on it and tapping it opens voice dictation.

How do you prevent this key from showing up?

Note that the instructions at http://osxdaily.com/2012/05/04/turn-off-dictation-on-ipad-iphone/ do not work; the Keyboard menu does not contain a Dictation toggle.

  • 2
    Not sure why you want to do this. The keyboard detects when you are typing and makes the dictation button activate the space bar. – Kevin Chen Jan 16 '13 at 19:08
  • @KevinChen, that's accurate if I'm typing quickly. If I'm typing more slowly, when I pause the dictation button is again active. – corvec Jan 16 '13 at 20:07
  • It also makes a really annoying noise when this happens, even with my phone on silent. – corvec Jan 16 '13 at 20:07
2

There are four things that you can try:

Disable Siri

You can disable Dictation by disabling Siri. Navigate to Settings > General > Siri and turn Siri "Off".

Update PList File

However, understandably, you may want to use Siri, and since you have a jailbroken phone, this appears possible by editing a .plist.

As per this MacRumors post, edit the file /User/Library/Preferences/com.apple.keyboard.plist. Edit it to add the following lines inside of the <dict> block:

<key>DictationOnSpaceKey</key>
<false/>

Update a different file

Using iFile, edit the file /Users/Library/ConfigurationProfiles/UserSettings.plist

Set restrictedBool > allowDictation > value to Off or false. It should look like this:

<key>allowDictation</key>
<dict>
  <key>value</key>
  <false/>
</dict>

Install "NoDictation"

NoDictation is a free jailbreak tweak available from the BigBoss repos (available by default on most iOS jailbreaks). If neither of the previous options work, it may.

  • @corvec, Interesting. What about post #11 (the last one, and by Intell) on the post that I linked to? Does that work? EDIT: I see you found that before my comment. Let me know what happens. – bassplayer7 Jan 16 '13 at 19:59
  • @corvec, have you looked in (Restrictions) Parental Controls? I can't look myself this moment but I suppose it's possible that functionality could be disabled in there. – bassplayer7 Jan 16 '13 at 21:20
  • @corvec, Try enabling restrictions, set a password you will remember, and then see if Dictation is in there. I doubt it is but it is worth looking. It's looking like Dictation and Siri are +/- one entity. – bassplayer7 Jan 17 '13 at 14:24
  • let us continue this discussion in chat – corvec Jan 17 '13 at 14:55
2

Settings > General > Keyboard > Enable Dictation - Switch it to off.

  • Per the OP's question, they are not seeing the setting you reference in your answer. – tubedogg Oct 26 '14 at 3:52
  • Sorry tubedogg-I see that now. Sorry. I just did that though, and it worked for me. Go figure. :) – McFluffy Oct 26 '14 at 9:44
  • As of iOS 8.1 on an iPhone 6+, those instructions work - so that's something, at least. – corvec Oct 27 '14 at 20:40
1

Disabling Siri is the only way I can think of. Go to Settings > General > Siri > slide the switch to Off

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .