When I am working on something else on my iMac, I tend to get a lot of messages via the Messages app. For some reason, when I click once on the messages app window, it does not get focus right away: Therefore, I usually double-click (Perhaps its a habit from MS Windows). When you double click inside a chat area, it opens up that specific chat conversation into a new chat window - which is extremely annoying (IMHO).

Is it possible to turn off the feature of opening that chat conversation in a new window?

I am running 10.8.2 and Messages version 7.0.1 (3314).

EDIT: So some further testing - This happens when:

  1. A different chat session is selected
  2. Messages does NOT have focus
  3. I click into a different chat session inside of my Messages window
    • this requires two clicks, 1 click to gain focus, 1 click to change chat windows.

All I am looking to do is disable the chat session from opening up in a new, independent window.


Unfortunately this is something that isn't possible. As you are aware, the only control we have over any double-clicking in the "Double-Click Speed" in Mouse preferences. Any changes here would be undesirable as it would affect the entire system and your goal is just the Messages app.

There is a convenient keyboard shortcut, Command + W, to close the new window that comes up, so at least you don't have to go over and manually close the window.

I suppose this is a feature request that doesn't come up very often but you could at least do what you can and fill out a feature request.


Try single clicking instead of double clicking. You could also try clicking somewhere else in the window, for example the Title Bar, or the message composition area. Double clicks in these areas should have the same effect as single clicking.

  • please see edit, but thank you for your reply.
    – Zero
    Jan 15 '13 at 16:50
  • If a new window is being opened then it is still interpreting it as a double click. Try slowing your clicks down, or adjust the click timing in System Preferences. You could also try Command-Tab to get to Messages. Maybe I'm just not understanding the problem.
    – Ɱark Ƭ
    Jan 15 '13 at 16:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .