29

I want know how can I apply a software to open all my same document, for example I want to open all my PDF document with Skim but when I right click on it> open with > other and choose my desired application and check the "Always Open With" it just do for that specific file.(mean always open A.pdf with skim if I want to open B.pdf still open with "preview").

How can I force OS X to open all pdf type with Skim.

alt text

3
  • Out of curiosity, what OS version are you using? 10.6? (this isn't relevant to the question, I'm just a curious dude ;))
    – Matt
    Jun 9, 2014 at 23:49
  • this question is too old that time I had snow leopard
    – Am1rr3zA
    Jun 10, 2014 at 6:45
  • I didn't even know it was the intended behaviour! I thought it was a bug in my Mac that it kept opening XMP with Photos, when I already "told it many times" to open it with XML editor.
    – texnic
    Jan 7 at 10:40

4 Answers 4

65

From the Finder, select a PDF file, open the Info panel (FileGet Info or I), select your preferred application and then click Change All…

change all

8
  • 1
    The UI related to changing default documents is misleading. I'm reading this question because I'm seeing this in 10.10.4 -- set TextWrangler as the default (Always Open With) for XML via the Open With... dialog, yet it still wants to open with Xcode. Your fix fixed it. Apple needs to fix this behavior.
    – jcollum
    Aug 24, 2015 at 14:54
  • 3
    now is 2016 and this answer is still useful, thanks!!
    – hihell
    Apr 9, 2016 at 18:03
  • 4
    2019... still useful :D
    – Teddy
    Apr 26, 2019 at 10:43
  • 5
    2020...still useful :)
    – MIK
    Feb 6, 2020 at 2:19
  • 4
    2021... Still useful. I've been using the "Choose application" for years and it doesn't work, finally stumbled upon this. Solutions which recommend using Automator, Services or editing Info.plist are pragmatically better, but until the OS provides something, this technique is easier to train and support others on.
    – tresf
    Jan 28, 2021 at 19:58
6

If you want to mess with all filetypes and "who opens what", there is a freeware System Preference Pane called RCDefaultApp that works in Snow Leopard, Leopard, Tiger and Panther.

You can change pretty much any type of resource, for example you can tell that “Acorn” opens png by default or that the default app for the extension “jpg” should be Preview.app, etc.

It also handles MIME types, URLs, and Media.

0
2

I had this problem today as well (Mavericks) but the solutions here didn't work. This is due to a corrupt services cache. I ran the following command in terminal and things started working again

/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -r -domain local -domain system -domain user

So if anyone the answers don't work for you, run this command and then it should be fine after that

1
  • is there any documentation for this command?
    – JGurtz
    Oct 10, 2020 at 23:31
1

Another option is to right click the file in Finder and then change "Open With" to "Always Open With" by holding down the option (⌥) key.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .