I have a 1TB Western Digital external hard drive that I use for Time Machine backups (and storage of a few other large files). Recently (since Mountain Lion, I think) I've been getting the following message when ejecting the drive:

"Time Machine Backups" is a partition on a disk that has 2 partitions. Do you want to eject "Time Machine Backups" only, or both partitions?

I haven't partitioned this drive myself, and I didn't get this message before a few months ago. According to Disk Utility, there is only one partition occupying the entire drive.

This isn't really a problem in itself (I just choose "Eject All"). However after ejecting the drive (all partitions) and waiting for it to disappear from the Finder, I still get the following message when I physically unplug it:

The disk was not ejected properly. If possible, always eject a disk before unplugging it or turning it off.

I don't want to damage my drive, so can anyone shed any light on what's going on? It's worth noting that neither of these problems seem to occur if I eject before Time Machine performs a backup.

Update 1:

diskutil list gives the following output:

   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *250.1 GB   disk0
   1:                        EFI                         209.7 MB   disk0s1
   2:          Apple_CoreStorage                         168.3 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3
   4:       Microsoft Basic Data Windows                 80.9 GB    disk0s4
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                  Apple_HFS Macintosh HD           *168.0 GB   disk1
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk3
   1:                        EFI                         209.7 MB   disk3s1
   2:          Apple_CoreStorage                         999.9 GB   disk3s2
   3:                 Apple_Boot Boot OS X               134.2 MB   disk3s3
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                 Apple_HFSX Time Machine Backups   *999.5 GB   disk5
  • What does diskutil list say about the partitions on the disk?
    – MacLemon
    Jan 14, 2013 at 3:56
  • 1
    I've updated my question with the output of diskutil list
    – C106
    Jan 14, 2013 at 18:18
  • 1
    That surely is not the whole output for /dev/disk3.
    – MacLemon
    Jan 14, 2013 at 18:24
  • 2
    I've added the complete output of diskutil list
    – C106
    Jan 14, 2013 at 23:29

2 Answers 2


disk3s3 is the extra partition on the time machine disk which OS X is complaining about. From what I have read (https://discussions.apple.com/message/19675983#19675983) this is a partition called "Boot OS X" which might have been installed on your time machine disk around the time of upgrading to 10.8.2. According to the linked article, this partition contains a copy of the Recovery Partition (http://support.apple.com/kb/ht4718) which you can boot from in the event that you cannot boot from your primary hard disk. This will only give you access to Recovery Mode, not a full OS installation.

I have observed that this partition is not mounted when you plug in the time machine disk (use the "mount" or "diskutil activity" commands to see this) but instead appears to be mounted when Time Machine finishes a backup. I don't know why it does this.

When you "eject" the disk from the Finder, you probably need to wait a few seconds before unplugging it. When the drive icon disappears, this probably means that the main time machine volume has been unmounted, but maybe it is still unmounting the recovery partition. This is likely the cause of your error message about having unplugged a disk without ejecting it. If you are paranoid, type "mount" to see all the mounted volumes, and verify that the time machine volume is no longer mounted before unplugging the disk.

  • 1
    Yeah, this matches with my experiences. I've found that waiting 10 seconds after the drive icon disappears before unplugging the drive prevents the error message. It's a bit annoying (and an example of horrible UI design), but now that I know what's going on it's easy enough to avoid the problem.
    – C106
    Mar 15, 2013 at 0:09

Since the OS starts by assigning disk numbers at /dev/disk0 and working it's way up, it appears that you truncated the output from the diskutil list command. It appears that there are at least three other physical drives connected.

Are you sure you are unplugging only the disk you ejected and no others? For example, you aren't unplugging a USB hub or keyboard with other drives plugged in.

Make sure you wait long enough before unplugging the drive from the system. I wait for the drive to disappear from the desktop and then wait another five seconds or so before unplugging the drive.

Do you have two partitions with the same name? (i.e. "Time Machine Backups") This is allowed, but it can get confusing which is which. If so, Try unmounting the drive from the "Disk Utility" app, instead of from Finder. Once the disk utility displays the item as grey, then it is OK to unplug.

Good Luck.

  • 1
    Yes, I truncated the output. I have updated my question with the full output. I am certain that the only thing being unplugged is the hard drive. It's usually the only thing connected anyway. I tried waiting 5 seconds after the drive disappeared from Finder before unplugging - still got the error message. There's only one partition called "Time Machine Backups".
    – C106
    Jan 14, 2013 at 23:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .