I'm developing an app, and one of the requirements is to connect to a computer with the URL scheme:


The problem, however, is that I can't connect to my Mac remotely.

Let's say my public IP is xx.xxx.xxx.xxx.

I have a Time Capsule setup as my router, and I enabled port forwarding for port 24001, mapping it to my computer's LAN IP, (DHCP reservation).

So, I saved the settings in my Time Capsule, then attempted to connect like so:


That didn't work, so I tried just connecting the following way:


Which game me the Safari can't connect to the server. error.

I double checked the Time Capsule, then made sure my machine's firewall was turned off, and tried again: no luck.

Finally, I ran a Port Scan test in Network Utility, and it wasn't seeing port 24001 as open at all.

So then I tried forwarding the port to a different computer,, which showed it as closed also.

What am I doing wrong, exactly?

  • You were elsewhere on the internet and not on the net served by the Time Capsule when you tried connecting? – Thorbjørn Ravn Andersen Jan 12 '13 at 0:40
  • No, I was still on the TC's connection when attempting to connect. – Charlie Jan 12 '13 at 0:49

You must log in to answer this question.

Browse other questions tagged .