I purchased Corsair RAM memory (2x4GB) CMSA8GX3M2A1066C7 from Amazon.com. According to the description it "Works with any Mac computer that supports 4GB DDR3 SODIMMs". My MacBook supports 6GB officially and 8GB with the firmware that I am running.
However when I inserted my MacBook sounded three beeps at start-up. I tried inserting only one stick in both of the slots but that didn't help. I also tried it with both sticks but that does not work either.

When I plugged in my old RAM it worked perfectly. I also tried another 8GB RAM stick from Crucial with the same specs (CT2CP51264BC1067) and it also worked as expected.

I tried the 2x4GB sticks with my HP laptop (dv6) but I got a blue-screen when booting with the messag IRQL NOT LESS OR EQUAL‎. The 8GB Crucial RAM works fine in the HP so there must be something wrong with the 2x4GB sticks

Has any of you experienced a similar issue? Is there anything I can do? I already tried PRAM reset.

Unfortunately I cannot return it as I am not in the US anymore.

  • 1
    This is interesting. Only today, I have been trying to upgrade by MacBook Pro (late 2008) with a slightly different Corsair 2x4GB kit (CM3X8GSDKIT1066G) and getting the same 3 beep error. Also tried in a Samsung laptop and getting blue screen. Faulty batch of Corsair 2x4GB kits??
    – user38409
    Jan 11, 2013 at 22:59
  • @MD55: Go for crucial. There are less problems with them.
    – Giorgi
    Jan 12, 2013 at 12:44

3 Answers 3


3 beeps indicate that the RAM didn't pass the system test. As the 2x4GB Corsair RAM also gives you a Blue Screen Of Death on your HP I would say that the RAM is faulty and your only option is to return it.

Try shipping it to a friend in the US or to Amazon.com directly as you're not in the US anymore.

  • Actually it's the Corsair ram giving BSOD, Crucials work fine.
    – Giorgi
    Jan 11, 2013 at 14:29
  • Sorry, I read over Corsair and thought it said Crucial. Jan 11, 2013 at 14:32

I have the same problem, I just bought a 2x4go Corsair Kit (Mac Memory DDR3 SoDIMM, PC-8500 1066 Mhz CMSA8GX3M2A1066C7) for my late 2008 Macbook.

I have the latest firmware and OS needed for the upgrade but when I installed it and tried to boot my mac: black screen and awful BEEP, BEEP, BEEP (my heart skipped a beat at that moment). I took them out, put them back in case I did it wrong the first time. Nothing. Put the old RAM in and it's working again.

I wasn't keen on buying Corsair RAM because of all the bad reviews I read but they were the only 8go available. I'll get them refund, I don't want something unreliable that's going to fail me in 3 or 6 months. Same RAM and we have the same issues. So I guess these definitely have some technical problems.

So far, from all the reviews I've read the one that have the less negative comments are G.Skill and OWC (but they're not the biggest manufacturers either), then it's Crucial and Kingston (1 on 20). And last Corsair (1 on 10). And read lots of comments saying to avoid "value" RAM as well.

Corsair RAM have lifetime garantee for these (or maybe not... but it goes from 2 years to a lifetime) get in contact with Corsair (website), you'll probably be able to get a refund or an exchange directly.


If I recall correctly, the 2008 MacBooks ran DDR2 RAM, not DDR3. The pin configuration is physically different between the two.

To be sure, you can remove one of the current sticks and hold it up next to a new stick. The notch on the pin side should be in a different spot.

I'd bet you got the beeps because you were not able to seat the sticks all the way in. Had you, you could have damaged your memory controller.

  • They run DDR3, not DDR2
    – Giorgi
    Jan 11, 2013 at 14:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .