1

I am using Mountain Lion on my MBP, my external TFT monitor used to work great at its native resolution (1920x1080) when connected to the MBP.

However today after shutting it down and powering it up the resolution on the external monitor was on 800x600. In system preferences the 'Best for Display' resolution output was selected (wasn't that supposed to be 1920x1080?) when I clicked 'Scaled' and chose 1920x1080 the resolution indeed changed, however it is not taking up the whole screen. There are 1 inches to the left and right of the monitor that are not being used. Its as if the viewport is "shrinked".

I tried downloading SwitchResX but it did not help, when choosing 1920x1080 again the viewport is missing about an inch to the left and right.

Any thoughts?

  • Have you tried unplugging the monitor, switching it off, and reconnecting it after a reboot. I sometimes find my external monitor doesn't get correctly detected and then needs to be "reset". – BinaryMisfit Jan 11 '13 at 10:33
  • This combined with a reset in the Modeline somehow made it work. – Panagiotis Moustafellos Jan 11 '13 at 11:09
1

I had precisely the same issue, and so did this poster: External monitor randomly lowers resolution adds black borders

the answer in both cases was to switch out the VGA cable.

0

If it once worked and from out of nowhere it doesn't, go to System Preferences -> Display

In the Display tab hit the "Detect Displays" button. If you can't find this button, hit the key (then the Gather Windows button will change to Detect Display - this is btw the most stupid GUI flaw I've ever seen).

This should fix your problem.

If it doesn't check your monitor's firmware settings (and maybe try to recalibrate it).

  • Thanks for your answer however it did not solve it. The monitors are being detected, the native LCD in its correct resolution though, while the external TFT is being set to 800x600. Funny thing is that in 800x600 mode the whole physical viewport is being used. When set to "scaled" 1920x1080 again the viewport is shrunk 2 inches horizontally. – Panagiotis Moustafellos Jan 11 '13 at 10:42
  • I have to calibrate the viewport of my Screen also independently for every resolution. Have you already tried to change the viewport manually with the monitor prefs? – cyphorious Jan 11 '13 at 10:45
  • The monitor is an LG Flatron E2211, a low-end 22" inch monitor that has just a few settings in its menu, there is no viewport settings built in. I tried recalibrating through System Preferences as well as through SwitchResX to no avail. I must admit it is very frustrating. – Panagiotis Moustafellos Jan 11 '13 at 10:47
  • Have you tried changing the Refresh Rate? I know this doesn't seem to directly correlate to the view port... but at least you could try. – cyphorious Jan 11 '13 at 10:52
  • I tried swapping the refresh rate trough Modeline, it mostly came out of sync, except if lowering it under 60Hz. There would be artifacts in the screen though so I reverted back to 75Hz/60Hz – Panagiotis Moustafellos Jan 11 '13 at 11:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .