I have an external hard drive (Drobo 2nd gen) connected to my Mac via Firewire. It used to appear on my desktop and in my Finder sidebar, but now it won't show up in either place (I do have "Hard disks" and "External disks" turned on in the Finder sidebar options).

The drive does seem to be mounting fine: the drive and partition are visible in Disk Utility and I can browse to it in Finder if I use the Finder's "Go to Folder..." command and type /Volumes/Drobo/. I can read/write to it fine once I've navigated to it.

I have the latest version of Drobo's Dashboard utility installed, and my firmware is up to date. Any ideas? Is this a sign that my external drive is starting to die?

EDIT: I've resolved this problem with the help of Drobo's tech support. See my own accepted answer below. I've revised this answer to make it less Drobo-specific, since it ended up being a filesystem thing.

  • Have you worked through any of the drobo troubleshooting steps? Link to them if you have questions on a specific step, but you can always chalk up hardware failure as a reason for something not working.
    – bmike
    Commented Jan 9, 2013 at 23:36
  • I've looked through the support pages but can't find anything that seems related. There's lots of troubleshooting stuff about a Drobo that won't mount, but that's not the issue here. I feel like it must be a configuration problem, since the only difference is the Mac. I've contacted Drobo's customer service, so we'll see if they have anything to say.
    – Hank
    Commented Jan 10, 2013 at 0:55

3 Answers 3


With the help of Drobo's technical support who pointed me to this MacRumors thread, I've resolved the issue. It turned out that somehow my drive got set to "invisible", which is a filesystem attribute. I don't think this setting is settable via the Finder, so I'm not sure how it got set like that.

To confirm the issue, I had to install Xcode and then install the command line tools, then run this Terminal command:

GetFileInfo /Volumes/Drobo/

where /Volumes/Drobo/ is the path to the volume in question. This command returns all the attributes set for that volume. If the list of attributes includes a V (capital V), it means that the volume is invisible.

To fix it:

SetFile -a v /Volumes/Drobo/

with a lowercase v, to remove the invisible attribute.

After a reboot, everything was back to normal.

Note: depending on the drive and your permissions, it's possible you will need to run these commands with sudo, although I didn't.

  • 1
    The shareware app PathFinder <cocoatech.com/pathfinder> allows you to see invisible files and volumes. It also allows you to set the attributes via a info window. There is a 30 day demo that allows you to use all of it's features.
    – Ɱark Ƭ
    Commented Mar 6, 2013 at 14:19
  • Thank you! I was heading towards a panic with this exact same issue, and I happen to be a user of PathFinder. Took just a couple seconds to remove the Invisible flag. How it got set, I'll never know... but I'm sure glad I could unset it!
    – JVC
    Commented Jun 5, 2016 at 22:27

There is a quicker way to do this without Xcode

Applications -> Utilities -> Terminal

chflags nohidden /Volumes/Drobo/

That should achieve the same result.

  • To show the flags: use ls -lO /Volumes. Commented May 23, 2021 at 17:44

Since the storage works just fine, it's more likely a problem with the software and/or a mismatch between your drobo software and the firmware on the device than it is a problem with the hardware.

Have you checked this article - specifically making sure you have no firewall (Mac OS X or something else like Little Snitch).

It's always possible that the portion of the Drobo that should be sending your Mac information has failed, but that's not as easy to fix other than attempting to re-flash the firmware. I'd personally open a support ticket with Drobo to be sure you are getting the best advice before flashing the HW.

Also, when OS X mounts a new drive, it will check the filesystem and since Drobo reports such a huge size, this could take a very long time before the icon shows up. I've seen this take more than 24 hours - expecially when the Drobo software doesn't see the device or is having issues helping drobo's filesystem get mounted in a timely manner.

  • Thanks for the leads, although my firewall is off, and anyway Drobo Dashboard has no issues seeing the Drobo. Do you think this could be a permissions problem issue carried over from the old computer? I'll try leaving the computer on for a while to see if it self-resolves.
    – Hank
    Commented Jan 10, 2013 at 3:38
  • Hmm - if the drobo software sees it, you can work with it in finder once you Command - Shift - G to navigate to the path, then either the desktop is corrupt and you can delete ~/.DS_Store and log out / back in or wait for Finder to be done sniffing the drive and mount it on the desktop. Sounds better than I assumed.
    – bmike
    Commented Jan 10, 2013 at 3:41
  • It turned out the filesystem "invisible" attribute got set somehow on the drive. Unrelated to Drobo. See my own answer, which I've accepted. Thanks for your help!
    – Hank
    Commented Jan 20, 2013 at 19:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .