2

I've been using the X-Fi for some time on Windows and it works great. However, on my MacBook Pro I can't get the volume control to work.

I see the device in "System Preferences -> Sound" and in "Audio MIDI Setup" and I can switch output to it and it works great, except for volume control. Is it possible to get it to work too?

5
  • 1
    Vlad - I merged all the 4 tags you created into audio since we probably don't need a ton of new tags for people to find audio related questions to filter out or search to answer. Hit me up in the better tagging room on chat if you have questions on when to make a new tag rather than using the ones we have.
    – bmike
    Jan 10, 2013 at 0:24
  • So it's digital output right?
    – Shane Hsu
    Jan 18, 2013 at 8:51
  • Yes, the Mac sees the soundcard as digital output. I'm using it to listen to music on my headset so it's pretty annoying that the volume control/knob is not working
    – Vlad
    Jan 18, 2013 at 9:09
  • Are you asking about volume controls on the X-Fi hardware, or the volume controls on the Mac/Mac OS?
    – iynque
    Jan 20, 2013 at 18:58
  • @iynque neither work. I would be happy if I could get any of them to work.
    – Vlad
    Jan 21, 2013 at 12:52

1 Answer 1

1

The workaround I found so far is to use Soundflower as an intermediate filter between PC output and the X-Fi. This allows to control volume from Mac OSX at the price of some sound processing. I cannot comment yet on sound quality but on first auditions it seems to sound better than setting the volume to 1/100 in Songbird (my FLAC player).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .