Last Dec (2012) my MacBook Pro (OS X Lion) started freezing, say 3 or 4 times a session. I ran both the Apple hardware diagnostic DVD (ran for hours, no problems), and I ran a disk scan, no problems found.

The kernel.log message turns up these messages, at every single crash:

Dec 13 07:29:27 Gord-Waits-MacBook-Pro kernel[0]: CODE SIGNING: cs_invalid_page(0x1000): p=809[GoogleSoftwareUp] clearing CS_VALID
Dec 13 07:41:17 Gord-Waits-MacBook-Pro kernel[0]: CODE SIGNING: cs_invalid_page(0x1000): p=839[ksadmin] clearing CS_VALID
Dec 13 07:41:18 Gord-Waits-MacBook-Pro kernel[0]: CODE SIGNING: cs_invalid_page(0x1000): p=840[ksadmin] clearing CS_VALID

If you google for GoogleSoftwareUp you find a number of internet posts with the same problem. I found one page that suggested I turn off the update by issuing this command:

defaults write com.google.Keystone.Agent checkInterval 0

which is supposed to disable auto google updates completely.

That drastically reduced the crashes, but I still get a crash about once or twice a week, with the same Google Update related messages.

Anyone have any new ideas?

I suppose I should uninstall Chrome altogether next..

  • Could you add what kind of crash you got: a browser crash, a kernel panic, a freeze of an application or something else?
    – dan
    Jun 24 '13 at 9:14
  • It simply froze. The entire operating system. No mouse movement, no activity, the screen showing what ever was running at the time of the freeze.
    – Gord Wait
    Jun 24 '13 at 15:10
  • On Snow Leopard, since the date of installation of this directory: ~/Library/Application Support/Google/RLZ I get every hour the cs_invalid_page error message in /var/log/kernel.log.
    – dan
    Jun 25 '13 at 11:11
  • I wonder how to get Google's attention on this?
    – Gord Wait
    Jun 25 '13 at 15:38

These misbehaviours seem to come from a Google software update agent.

If this command:

launchctl list | grep google


-       0       com.google.keystone.user.agent

Then you may temporarily stop this agent with:

cd ~/Library/LaunchAgents
launchctl unload -S aqua com.google.keystone.agent.plist

On the system (where I do have regular crashes since the installation of this agent: Snow Leopard) I noticed that this plist is starting an executable located here:


which is a universal binary dating from May 2012:

file GoogleSoftwareUpdateAgent 
GoogleSoftwareUpdateAgent: Mach-O universal binary with 2 architectures
GoogleSoftwareUpdateAgent (for architecture i386):      Mach-O executable i386
GoogleSoftwareUpdateAgent (for architecture ppc):       Mach-O executable ppc

Hence I'm tempted to conclude that this agent is using obsolete code and should be removed.

I removed this agent so as not to see it again on my next session with:

cd ~/Library/LaunchAgents
chmod 0 com.google.keystone.agent.plist

Tested with a new session. I have no more CODE SIGNING: cs_invalid_page(0x1000):[…]


Eventually I discovered that both Chrome and Chromium had an instance of Google Update running in parallel, and they weren't playing well together(I'm 90% positive, but not 100%. Grain of salt required).

One at a time I uninstalled each Google App the Macbook stopped crashing.

When I got rid of Chrome I still had crashes and a copy of Google Update running. That's when I remembered I had Chromium installed.

After I uninstalled both Chrome and Chromium my Macbook became stable again. I left it for a week, then installed vanilla Chrome, things were still fine. A week later I installed Picasa, still ok.

Still ok now after a few months.


Exact same thing here. After some research I've just tried this.

We'll see how it goes.

  • I'll try it out. I am concerned I have a hardware issue and the updater is just setting off the problem, but we'll see what happens!
    – Gord Wait
    Jan 11 '13 at 7:17
  • I tried that method, and discovered that One: Google Chrome started to complain that it was unable to update, and offered to fix the problem, and Two: My Macbook crashed again with the same GoogleSoftwareUp message as the last thing in the kernel.log. I then realized I had Chromium installed, as well as Google Earth, Picasa and Sketchup. I like these programs, but to diagnose this I removed all Google software from my system for a while to check stability. Perhaps one of these other packages had a stale or buggy copy of GoogleSoftwareUp, or was interfering with the Chrome copy.
    – Gord Wait
    Jan 15 '13 at 23:05

Lion and Mountain Lion cause kernel panics on 2010 MBP's. Search the web, it's a well known issue by now. I solved it by downgrading to Snow Leopard. Get yourself a copy of 10.6.8 and put it on a USB drive or stick, do a clean install (I know that's a drag but it's the only way!) and you'll have no more issues.

  • My Macbook pro is mid 2009, not 2010. This is not the same issue. After a week with no Google software I've had a week with zero crashes (a drastic improvement from a couple crashes per session). I have since upgraded to Mountain Lion, no crashes. New Google Chrome. No crashes. Problem was two copies of Google Updater running at the same time: a stale copy of Google Updater (Chromium?) and the latest Chrome. The GoogleSoftwareUp crash seems to be fairly rare, but is found on the web, and is unrelated to the 2010 MBP issue.
    – Gord Wait
    Jan 22 '13 at 16:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .