34

One of the new features of Mountain Lion is the fact that one can sync iMessages across iOS and OSX devices.

I would really like to have a thread that I start on my iPhone automatically sync to my Mac and iPad so I can reply easily from either device. I do understand that SMS text messages will not sync, and only iMessages.

This question applies to iOS 6 and Mountain Lion devices as I am running an iPhone 4S and 3rd Gen iPad with iOS 6 and a Macbook Pro with Mountain Lion (OSX 10.8).

How can I enable this feature so that my iMessages stay in sync across all my devices?

34

iOS (6 and later) combines your phone number with your Apple ID email address, which makes it possible for others to iMessage your phone number and have those Messages sync across your devices.

First, you need to make sure all your devices are on the same Apple ID.

On each iOS device (iPhone, iPod Touch, iPad, iPad Mini):

  1. Open Settings.app
  2. Go to "Messages" and make sure iMessage is On.
  3. If iMessage is on, "Send & Receive" will appear below it. Tap on it.
  4. Make note of the Apple ID at the top of the page.
  5. Select your phone number and email address(es) that you want to sync to that device.

On each Mac: (Mountain Lion or later)

  1. Open Messages
  2. Click Messages -> Preferences
  3. Click the "Accounts" tab in the top.
  4. Select your iMessage/Apple ID account, and make sure "Enable this account" is checked.
  5. Select your phone number and any email address(es) that you would like synced.

The most important part is that everything is consistent across all devices that are necessary.


Message History

The steps described previously will not automatically cause old iMessages to sync across all devices. However, iOS and macOS now support "Messages in iCloud": Apple Support Document. Enabling Messages in iCloud will sync historical messages across all of your devices. Make sure you are running the latest version of macOS or iOS.

To turn on Messages in iCloud on your iOS device:

  1. Open Settings app.
  2. Tap your Apple ID profile at the top of the list.
  3. Select iCloud.
  4. Enable Messages.

To enable on your Mac:

  1. Open the Messages app.
  2. In the menu bar, select Messages -> Preferences.
  3. Open the iMessage tab.
  4. Select the checkbox to Enable Messages in iCloud.

Additional Troubleshooting steps

If you are still having trouble getting new iMessages to sync across the devices try:

  1. Disabling then re-enabling iMessage on each device that isn't being synced to.
  2. Delete all your previous conversations: Some people have reported that they had to delete all of their conversations before things would sync up.
  3. Make sure you have your phone number added to your Apple ID account online.
  • 3
    this is just way to complicated for a simple task like this… Are less steps possible for setting up new devices? – user58036 Sep 25 '13 at 1:50
  • 2
    Yep, it's actually all very easy and simple. The answer above is comprehensive, therefore it looks harder/longer. Just sign into your Apple ID on your iOS/OSX device and make sure iMessage is on. The rest just happens. – bassplayer7 Sep 25 '13 at 13:33
  • 4
    Except when it doesn't. – daniels Dec 9 '16 at 10:45
  • 1
    And, FYI, history will sync in iOS 11/macOS High Sierra, IIRC. – Harv Aug 8 '17 at 19:08
  • FYI I ran into this question on a new MacBook using Catalina. Historical messages do sync, but you have to make sure you've signed in to your Apple account for your MacBook as a whole. To do this, go to System Preferences and verify that your Apple account is at the top. If instead you see a prompt to sign in, you have to do that. AFTER doing that, go to Messages->Preferences->iMessage, and click "Enable Messages in iCloud" and it will start syncing historical data. – Stephen Nov 26 at 2:54
5

I am on iOS 10.3.1 and macOS Sierra 10.12.3. I need to setup Messages in macOS using https://support.apple.com/kb/HT202549. In iPhone, the settings that allowed me to sync is in Settings > Messages > Send & Receive. I have to login my Apple ID here.

  • 2
    thanks great answer! is it possible to sync history too? – Tamas Kalman Apr 25 '17 at 19:27
  • 2
    I was replacing an old phone with a new one. iMessage didn't work until I disabled and then reenabled "iMessage" switch in Settings > Messages - for some reason, this forced it to reconnect to the mac. – Kristen Waite May 16 '17 at 21:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .