I installed Windows with Bootcamp and have an Airport Express. Every time I boot from Windows to OS X it connects to the wireless network but not to the internet. Other devices still keep their connection to the internet.

So, the only thing that makes this work is to turn Macbook's Wi-Fi off, turn Airport off (!) and turn on everything again.

The same problem also happens when I boot from OS X to Windows, but in this case is easier, since I only have to turn off and on the Wi-Fi.

The problem doesn't happen with my Linksys router.

I'm using Moutain Lion 10.8.2, Windows 7 x64 and I think I have the last Airport firmware version: 7.6.2. I'm using DHCP.

Do I have to click on the Bootcamp tool and chose Restart in OS X... option or can I simply restart the computer using the Start button?

  • 2
    Do you have the Mac drivers for Windows installed? apple.com/support/bootcamp – Ben Mordecai Jan 7 '13 at 3:57
  • Yes I do, though the day I installed Bootcamp wasn't working to download, so I got from another source. How do I know if I have the last version? – Roberto Jan 7 '13 at 11:11
  • There should be a Control Panel in Windows called "Apple Software Updates". Run it, and it will let you know if you have the latest version. You can always re-download the official Bootcamp drivers from the link provided by Ben and re-install. – OvQ Jun 23 '13 at 7:56
  • Ok, everything is updated, but nothing changed :( – Roberto Jun 24 '13 at 15:42
  • @Roberto you state that the problem doesn't happen with your Linksys router. Do you mean that it is not a router issue, or that it just happens on other routers except the Linksys you named? This is confusing. If the router is not related to this case, please remove it from the question. Additional, can you provide us which version of Windows you installed? Windows XP, 7 8, server 2003 2008 1012? x64? x86? Please update your question with the relevant details. – Rob Jun 25 '13 at 15:30

It sounds to me more like your Airport Express is acting up (since you mentioned that the Mac works fine with your older LinkSys router.) Check for a firmware update via Airport Utility.
Additionally, you can force Windows to release the DHCP lease on its IP address by going in to the Windows command prompt and typing

C:\Users\myusername> ipconfig /release

Just do that before you restart into Mac OS X. I agree with @Buscar that you should try to reinstall the BootCamp drivers (and check Windows Update for any updated drivers.)

| improve this answer | |

Every time I boot from Windows to OS X it connects to the wireless network but not to the internet.

Windows is not releasing the Internet connection, so try to stop it (turn off wifi) in Windows first to confirm.

If that is the case report it and we will work on next step.


Great so it Worked!..

At least you do not have to reboot to switch OS :)

Here is what I think is happening.

Since you had installation problems with bootcamp there is a driver that is not Releasing the Internet connection.

Since you can not have 2 Internet connections on one card, that is the problem.

If you want to do some analysis: Try running Netstat in OSX Terminal (after switching os without turning wifi off) and see if it shows it and confirms the theory.

Possible solutions:

1- Turn wifi off in Windows before switching the os.

2- Monkey around finding the specific driver to replace it ?

3- Make complete new Bootcamp install ?

4- Also see this for more information on similar problem

| improve this answer | |
  • Yes, that seems to work. But what do you mean by releasing the Internet connection? What is this? Does OS X get another IP? If so, it should be treated as another computer, if not it should keep the connection... ?? – Roberto Jun 27 '13 at 11:46
  • No it does not get another IP but it will used another driver for it. So when switching os normally all drivers from Windows would shut down and the OS x drivers would take over. Or something like it... – Ruskes Jun 27 '13 at 17:59
  • What parameters should I use with netstat? I'm not sure in what to look for there. I did the test again twice and this time it didn't work :( When I first did it, it probably worked because I switched very fast OSX -> Win -> OSX. – Roberto Jun 27 '13 at 22:40
  • You can not be faster then the computer :), what is happening is that the switching does not correctly change the drivers. Fresh new install is you best long term solution. Turning off the WiFi before switching is only temporary solution. Just type netstat and look for active IP, after you switched and before you turned on WiFi on os x. – Ruskes Jun 27 '13 at 23:16
  • About being fast, I thought about the router not timing out the IP designation to OS X, so when I came back to OS X it still knew that IP was his. One strange fact is that Windows reports that the connection is "not connected to the Internet" but it works. Don't you think it could be that it is wrongly reporting that has no Internet in both systems, but Windows dumbly tries it anyways - and works - while OS X wanna-be-smart blocks any Internet connection? How can it be the wrong driver if it's the same driver for the same machine for everybody? – Roberto Jun 27 '13 at 23:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .