1

I just got back to school today after using Ethernet at home.

The WiFi claims to be connected to my Macbook Pro, but I can't get any internet out of it here after an entire semester of working.

I tried resetting the PRAM. And "-"ing Wifi on the Network Settings.

The Ethernet at the University still works, but I can't stay plugged into the wall once classes start.

Anybody help?

  • What version of OS X? 10.8/Mountain Lion or older? – bmike Mar 22 '13 at 12:55
1

If I was you I'd visit this web page and properly set up your Mac for access to the new WPA2 Enterprise Wi-Fi network at the University of Alabama, but then that would be cheating.

0

Hold option, go to the Apple menu, and down to System Information. Go down to Network/Wi-Fi. Is anything listed? If not, you have a hardware problem and need to take it in to Apple.

  • Yes, I should mention the WiFi claims to be connected, I can't get any Internet from it. Know anything about that problem? – Michael Saggio Jan 7 '13 at 2:33
  • @MichaelSaggio - ah, that's an entirely different problem altogether. Does it only happen at one location or anywhere when you're on WiFi? – Harv Jan 7 '13 at 2:56
  • @MichaelSaggio - if it happens everywhere, go to your System Preferences -> Network, and see what your IP address is in WiFi. You should probably also be set to connect using DHCP. If you're getting 10.x.x.x or 192.168.x.x or 172.16.x.x IP addresses, you're good. If you're getting 169.254.x.x IP addresses, it's actually the network you're on isn't set up properly, or they need to provide you with more instructions (a Static IP, a certificate, or a username/password to connect with). – Harv Jan 7 '13 at 3:00
  • i keep getting a specific: 130.160.xx.xxx i was able to get a connection this morning in the airport too btw - but you had to pay so i didn't do it. thanks for the help btw! – Michael Saggio Jan 7 '13 at 3:48
  • 2
    @MichaelSaggio No problem -- I think whatever establishment you're at requires you to be registered in some way, either through a web page, username/password, certificate or otherwise. You'll need to talk to someone in IT to get this resolved: I don't think there's any hardware or software 'problem' here per se, that I can help you with. The computer's probably doing exactly what it should. – Harv Jan 7 '13 at 4:12
0

Looks like this is an old post, but thought my answer might help someone with this issue.

I had come across the same issue and resolved this by holding option key on restart. And it asked me to choose network, where I can find wifi networks visible. I selected one and continued. Then it worked fine.

  • Not sure you might fix the switching of WPA to WPA2 from the network of the University of Alabama so easily. – dan Nov 3 '15 at 22:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .