I have iMac (mid 2011) with latest OSX (10.8.2). Seems impossible to install windows without superdrive (it just doesn't work works fine on windows).

I have googled for solution but none of them worked. I tried bootcamp method, but when it restarts failed to find USB boot and tries to boot from bootcamp partition, which results no bootable drive found.

I am not sure if this is OSX restriction by apple, but All I know that I cant install it. If someone have any idea how to fake it or how to bypass this please let me know.


IT's all about installing windows 7 dual boot on iMac without DVD. I have edited plist file so I am able to Create Boot USB from bootcamp. When I click Install in boot camp, it creates partition as it should but when Mac restarts it wont boot from USB.

Edit 2: I have tried with refit, I can see my USB but when I want to boot from it it shows No bootable device error. I have created USB with both Basecamp option and Microsoft official USB creator. None of the worked.

  • It's not completely clear what you're asking here. Commented Jan 6, 2013 at 20:21
  • Consider listing the error you are getting or which step in Apple's bootcamp guide is failing you. You could also edit in the version of Windows so people don't have to guess that as well.
    – bmike
    Commented Jan 6, 2013 at 20:52
  • I've had the same exact frustration.. did you ever find a solution for this. BootCamp 5, Mountain Lion, Fusion Drive, External Optical Drive, Windows Boot USB Flash Drive, Windows 7 and absolutely no success. I've tried all the methods mentioned above as well as the Virtual Machine method, but it won't let me boot to the windows BOOTCAMP partition.
    – user41622
    Commented Feb 11, 2013 at 16:39
  • 1
    @Flakerim This article maybe of interest to you huguesval.com/blog/2012/02/…
    – Simon
    Commented Feb 13, 2013 at 14:36

2 Answers 2


It Doesnt work, I managed to do it with better CD and somehow it read it. Also when you do restart after bootcamp completes and ask to restart, don't hold option key, it will find it automatically where to boot from. Holding option and trying to boot from BOOTCAMP volume it doesn't work.


Have you tried virtualbox? It's an opensource virtualization tool. I've been using it on linux desktops and works pretty much the same as VMware.



  • This is not what the OP wants. Commented Aug 30, 2013 at 11:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .