I have what seems to be a common problem with iPhones (mine is an iPhone 4), a recovery loop, so I try to restore it but now I get this error:

"Unable to restore iPhone. Unknown error -1"

And it fails to restore after saying

"Restoring iPhone firmware"

I've tried using a local ipsw file (iPhone3,1_6.0_10A403_Restore.ipsw) however I get error 3194. I don't care about any of the data on the phone if that matters. I think the phone was jailbroken before the recovery loop.

How do I fix this and get some (any) firmware successfully into the phone?

  • It would be helpful to disclose your iOS version if you know it. Commented Jan 6, 2013 at 1:54
  • I don't know the version that was installed prior to the recovery loop :(
    – Sbx
    Commented Jan 6, 2013 at 3:49
  • I was having the same issue with my 3GS, and found that trying over and over (like 10 times) helps. Try deleting and redownloading the firmware, then installing it after the phone has been off for about a day or two. It sounds weird but I've had this "fix" the problem twice thus far.
    – Alexander
    Commented Mar 25, 2013 at 3:01

4 Answers 4


Did you try to update your iTunes before putting the iPhone on DFU mode? It should be the problem since I had this problem before and when I did update to iTunes it worked :)

  • Yes, I had the latest version installed.
    – Sbx
    Commented Sep 8, 2014 at 4:53

Per iDownloadBlog:

Step 1: Put your iPhone into DFU mode.

Step 2: Enable the TSS Server on TinyUmbrella. If iTunes is open, it will close.

Step 3: Open iTunes, and it should recognize your device in recovery mode. Hold Alt/Option+Click ‘Restore’ in iTunes, and select the iOS 4.3.3 firmware for your device

Step 4: Allow iTunes to restore. You may get an iTunes Error (1) when the restore is complete. This is due to the fact that the TSS server is still running, and can be misleading. Just ignore this error.

Step 5: Your iPhone should now be stuck in the recovery loop. You will see a “Connect to iTunes” message. Rebooting, booting out of recovery, etc will get your nowhere.

Step 6: Download the Fix TinyUmbrella Fix Recovery file for Windows or Mac via our Downloads page.

Step 7: Place your iPhone back into DFU Mode.

Step 8: Extract the contents of the fixrecovery.zip file, right click on ‘fixrecovery43′ and select ‘Open With’ then ‘Terminal’.

Step 9: The fix recovery should execute, and your iPhone will be kicked out of the recovery loop.

Step 10: Run iTunes with your iPhone plugged in to activate if necessary.

  • I cannot run fixrecovery43.exe on my system as I do not have 'zlib1.dll'
    – Sbx
    Commented Jan 6, 2013 at 3:49
  • Okay I got zlib1.exe now, but now I am getting this error when running fixrecovery43.exe
    – Sbx
    Commented Jan 6, 2013 at 3:59
  • What is the error when running fixrecovery43.exe? Commented Jan 6, 2013 at 4:03
  • paste.ubuntu.com/1502154 there is whole output of fixrecovery43.exe
    – Sbx
    Commented Jan 6, 2013 at 4:08
  • Yes I pressed run as administrator
    – Sbx
    Commented Jan 6, 2013 at 5:41

I have gone crazy trying to solve this problem trying everything tried above. If you have tried all the steps of restoring it, using apps like Tiny Umbrella and Redsn0w and things still are not working. This is an easy way that may fix your problem.

  1. Click on Finder so it is chosen in the top left corner. Click Go and choose Go to Folder.

  2. Type /etc/hosts anad press Go.

  3. Move the file hosts to the desktop then right click the file and press open with Text Edit. (Enter your password if asked through any step in this entire process)

  4. At the bottom of the page you will see these two lines gs.apple.com gs.apple.com

On your last line you will see that it does not have a # sign in front of gs.apple.com

Add the # sign and change the file and save it. It will ask if you want the remove the extension and choose yes.

  1. Move the hosts file back into the etc folder from which you moved it to the desktop to replace the file. If asked press Authenticate.

Now go and restore your phone!!!


Do one thing:

  • Download latest version of readsn0w and open it
  • you can see the option extra: click it (your iPhone must have in normal or recovery mode)
  • then you can find other option recovery fix: click it (after clicking this option put your iPhone in DFU mode)
  • wait till your iPhone start again (it might take 1 hour or so, just wait)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .