17

When I installed iTunes 11, for some reason it re-downloaded all my purchased "in the cloud" songs even though they were already in my library. So now I have duplicate songs, one that matches the cloud, one that has my rating, playcounts, etc. For example:

duplicate songs

I want to tell iTunes that they're the same songs- I tried to delete my old copy then, when it asks me to locate it, point to the new copy, but when I delete the cloud entry it doesn't realize that they're the same. Is there anything that I can do to fix this?

Note: I do not have iTunes Match, and this is on a Mac, if that's relevant.

Edit: Of course I could delete my local copy and download and use the cloud copy, but I want to keep ratings and play/skip counts.

20

Like Harry reported, the problem can be dealt with by disabling "Show iTunes in the Cloud purchases". But then you don't see your Cloud-based music if you haven't downloaded everything.

I found that re-enabling this option seemed to reconnect with Cloud and resolve the duplicates problem without losing any history.

  • 4
    This worked for me immediately -- uncheck the box, click OK, open preferences again, check the box, click OK. – Justin Jul 25 '13 at 14:04
  • 1
    That setting on the Mac is in: iTunes > Preferences > Store > Show iTunes in the Cloud purchases – Ciaran Jul 30 '13 at 6:19
  • 2
    To me it fixed by just logging out and in. – fiorix Oct 30 '15 at 15:06
2

Preserve meta data

Doug's AppleScripts for iTunes hosts a huge list if AppleScripts useful for managing iTunes. Of particular interest in this case are

Especially the first one seems to be very interesting in your case.

Replace tracks

You should be able to

  1. redownload the tracks by clicking on the iCloud icon
  2. transfer any meta data manually or with the AppleScripts listed above
  3. delete the current copy (the one not marked yellow in your screenshot) from iTunes and your hard drive

General note

To be on the safe side, make a backup copy of the titles in question first and run some tests using just a few tracks

  • yes, but the point of the question is that I want to maintain ratings and play counts – arolson101 Jan 6 '13 at 5:50
  • Good point. How many tracks do you want/need to fix (I don't want to propose a manual solution for thousands of tracks)? – nohillside Jan 6 '13 at 9:16
2

I solved this in the following manner.

Go to Preferences, then to Store, then uncheck the box that says "Show iTunes in the cloud purchases"

2

Note that iTunes 11.2.2.3 doesn't have "Show iTunes in the cloud purchases" in the Preferences->Store page; however it is still described in the help box description of that menu (which you get by clicking on the help button).

The logging into, and then out of the Store fixed this issue for me.

  • 1
    Commenter from the future? – dwightk May 29 '14 at 4:17
  • YMMV with this one. Just tried this with iTunes 12.9 and it only made things worse (I had maybe 15 duplicated "iCloud" songs before signing out/in and I now have 40 or so). What an absolute mess! It' beyond me that despite all their resources, Apple can get themselves to fix these issues that go back years and years... – sxc731 Sep 15 '18 at 15:15
0

I had the same issue this week, and the suggestion here turned out to fix the problem--I simply logged out of the iTunes store and logged back in. For whatever reason, that fixed the problem and made the duplicates disappear.

  • The first couple of ideas, about disabling "Show iTunes in the Cloud purchases" did not work for me. However, the one about logging out of the iTunes store worked first time. Thanks – user63578 Nov 28 '13 at 1:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .