4

I am assuming that this is an bug, but I thought I would check with you all first to see if that is the case.

I had been running OSX 10.6.8 with bootcamp 3.3 and Windows 7 64x PRO. I reloaded it over Christmas, to re-partition my drive. When I reloaded, my function keys were not working. I upgraded my OSX side to Mountain Lion, downloaded bootcamp 4.0 and installed that on my Win7 side, still no joy.

Here is what is happening. My driver is not installing at all. Even when I go in and try to manually try to install the driver, it comes up with an error that says "install failed". I have tried everything, including removing all drivers, and reinstalling them, and all of the other basics.

To further muddy the waters, I borrowed an OSX dvd that had bootcamp 3.1 on it. I installed that keyboard driver. Now my internal keyboard works, just like it should, with all of the FN keys performing properly. However, when I try to point my Apple Bluetooth keyboard to use that driver, I simply get an error.

Bottom line is, the 4.0 keyboard driver will not install at all. Built in keyboard is working properly on an old driver. And my Apple bluetooth keyboard FN keys are not working. I am thinking it is a bug with the driver, but does anybody have any ideas for me?

1

Try downloading and installing the Bootcamp Windows Support Software from here. With 10.7, 10.8 it automatically prompts you to save the support software on a disk or USB to be installed with your Bootcamp, if you are still running Snow Leopard you may have to download it manually.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .