This started two days ago and I can't decide if my MacBook is at fault, my router is at fault, or I have a hacker. My MBP will throw an error saying the IP address I've been using has been assigned to another machine and blah blah blah reset the router or contact my local admin. (Which is me; this is our home system.) I'll renew the DHCP license and the error immediately comes up again. Also happens if I am HARDWIRED to the router itself. (So if wi-if is on I get two errors simultaneously.) I tried changing my MAC address to something else, thinking it was a possibility the MAC address was being spoofed, but the problem continues. I have a linksys router and a cable modem.

We have three iPhone 4s's, two iPad 2's, and a Windows laptop or two (depending on whether he brings his work laptop home. We also have a few roku devices and two IP cameras (monitors for the kids' rooms). Oh, and the printer. I can see everything assigned to the router in the DHCP tables and never see the assignment of the old IP to another machine. I tried pulling out an older linksys router and the behavior has not changed. Security is WPA2 with a 16-char string that I have not yet changed. (My weak point; it's a pain to update those cameras.)

Any ideas? I'm not opposed to getting a new router if that's what it takes; I was prepping to do that later this morning anyway when stores open. But I'm afraid the new router will do the same thing.

Edited to add: yesterday I also tried powering down some of our iThings. When all phones and tablets were powered down the problem seemed to go away. But then it returned with a vengeance so I powered them back up so we'd be able to communicate with the rest of the world.

  • Did you check in the Network settings (of all systems) that they use DHCP?
    – nohillside
    Dec 26, 2012 at 10:15
  • Yes. I also tried assigning addresses via the router (the newer one, which is currently unplugged) to each MAC address in our system. All except the MBP accepted their assignments.
    – Valkyrie
    Dec 26, 2012 at 10:27
  • That is, the MBP would accept it but immediately I would get the nasty gram from the system.
    – Valkyrie
    Dec 26, 2012 at 10:35
  • Linksys firmware up to date?
    – AllInOne
    Dec 26, 2012 at 18:48

2 Answers 2


Once Macs are given a dynamic IP in a DHCP-based system they prefer to hold onto it at all costs, even with releasing/renewing. Check to make sure there are no static IP configurations for another computer that your Macbook is trying to use instead.

If there're no IP's configured statically then try resetting the router to default settings.


I ended up replacing the router with an airport and so far no problem. Linksys tech support finally responded and guessed that the DHCP server was malfunctioning. No firmware upgrades were available so they were in the "oh well, sux to be you" camp.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .