I have an iMovie project (stop motion animation). Everything is fine, except for a dark scene. The photos get pixelated and blocked, and really ruined. The original image is very sharp and clear, yet the one in iMovie and the exported video files is ruined.

The original media is not video. Rather, it is a large set of JPEG images (stop motion animation film). The images are 773 x 515 pixels, and very high quality. If it matters, it's being overlaid with M4A audio.

Other video editors (PiTiVi, Kdenlive) don't ruin it, so it's not a general issue.

Before iMovie:


In the final video:


Any ideas?

  • Could you maybe add some screenshots (or the actual video) so that people can help you better? Dec 25, 2012 at 22:27
  • @BartArondson: Done. The difference is ridiculous that iMovie did this.
    – Linuxios
    Dec 26, 2012 at 16:51
  • 2
    It looks like compression artefacts to me, so the compression quality should be raised. If you choose "Export with Quicktime" you are able to change the export quality. With what settings do you export the footage now from iMovie? Dec 27, 2012 at 17:35
  • @BartArondson: I'm using Export to Disk with MP4 as the codec. Let me see what you're talking about.
    – Linuxios
    Dec 27, 2012 at 17:38
  • 1
    Ok, I've tried doing the same with some dark footage of my won and I encounter the same with iMovie '09. Export Movie and Export with Quicktime give the same blockiness regardless of the bitrate I specify. I have no clue. I did flag moderator attention to this question as it may be more suited on the AVP stackexchange. Is there a specific reason you're using iMovie? As the easiest solutions right now seems switching editors... Dec 27, 2012 at 20:47

2 Answers 2


You need to set Data Rate in Export with Quicktime to Manual and increase Data Rate value for improving quality. You can also try compression quality after you have set a high data rate.

  • The problem is that it's not just in the output -- the footage is changed and compress before it's ever out putted to disk. I'll try though. Thanks.
    – Linuxios
    Jan 5, 2013 at 16:01
  • 1
    Make sure you choose the highest import setting (depending on quality it gives you 2-3 options). If the artifacting is still occurring, then you may need to unfortunately look at another piece of software. iMovie has scant options for controlling the settings of footage imported into the software. A program like Final Cut Pro will give you much more granular control over controls like this.
    – bispymusic
    Mar 7, 2013 at 18:57
  • what should you set the data rate at?
    – user67537
    Jan 15, 2014 at 7:46
  • The data rate is quite subjective so you have to test until you feel satisfy. Also a higher resolution requires a high data rate. Usually you can use Youtube's as a starting point, e.g., ~400kbps for 320p includes audio.
    – neo
    Jan 15, 2014 at 10:22

I had problems with the terrible export quality of imovie. The only thing I have found that works is to export to iTunes. This gives great quality but will be an mov file. Then you just drag out of iTunes onto your desktop and use any number of programs to convert it to what you like (handbrake?). Mov files are fine for my use. Glad I figured this out and just wanted to share.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .