My problem:

iPhoto opens automatically, when I:

  • Copy and paste any kind of file to my Desktop
  • Save any file type to my Desktop
  • Create a screenshot (which is automatically saved to Desktop)

iPhoto doesn't open when I:

  • Move any file type to my Desktop
  • Copy and paste a file anywhere in documents (not Desktop)

According to this I think the problem is with creating a file on the Desktop.

When the problem first appeared:

I tried to create a shortcurt to an application and looked through several blogs. I ended up in creating a test-service, which launches iPhoto. I wanted to map that service to a shortcut, but it didn't work out...

photo of automator application

What I've tried so far:

  • I've deleted the service I've created.
  • I went to System Preferences > Keyboard and "Restored all Defaults" in each category for all the shortcuts.
  • I've unchecked every Service in the System Preferences.
  • I went through the Preferences of iPhoto.
  • I searched Google for like 3 days.

Does anyone has any clue how I can fix this behavior?


Sorry the confusion: the behaviour hadn't anything to do with the service I've created. It was a Folder Action assigned to my Desktop.

  • Have you thought about re-installing iPhoto? Jan 5, 2013 at 17:02
  • Yeah - but how do I manage reinstalling it without paying the 15$?
    – Chris
    Jan 5, 2013 at 17:31
  • How did you originally get it? Have you looked in the Mac App store under "Purchases"? If iLife came installed on your computer, it should be available for re-download via the Mac App store. Jan 5, 2013 at 17:33
  • 1
    It came installed on the computer. When I open up the App Store I can see iPhoto under my purchased apps. However I don't see anything like a button the redownload the app which is described in here: macs.about.com/od/usingyourmac/qt/…
    – Chris
    Jan 5, 2013 at 17:47
  • 1
    I guess I don't see any reason why not (I just hate for there to be some major issue during the un/reinstall process). I just tested it by deleting the Evernote app. I then rebooted and under Purchases in the App store I had the option to "Install". I re-installed Evernote and all worked well, so un/re-install iPhoto should be easy. Jan 5, 2013 at 18:03

3 Answers 3


Have a look at Folder Actions Setup.

You can open this by right-clicking on any folder in your home folder, choose "Services > Folder Actions Setup ...".

You can also find it here: /System/Library/CoreServices/Folder Actions Setup.app

  • You got it right! It had nothing to do with the service I've created. I launched the Folder Actions Setup and was able to delete another iPhoto.workflow I've created before I set up the iPhoto service.
    – Chris
    Jan 6, 2013 at 11:47

Maybe the service is saved somewhere else? As far as I know, they go into ~/Library/Services/ (you can go there by switching to Finder and press Shift+Control+G or select "go to folder" in the Go-To-Menü).

Maybe you saved your Automator script as "Folder Action"? Have you checked them, too? I think they are visible as a submenu when Control-Clicking on the Desktop.

  • Thanks for the answer - the service was saved in /Library/Services, but I deleted it. Unfortunately, I don't see any "Folder Action" when I control-click the Desktop...
    – Chris
    Jan 5, 2013 at 17:35

Look in the folders

  • ~/Library/Scripts
  • ~/Library/Application Support/Apple/Automator

if you can find that automator script or workflow with the service where you included iPhoto.

Maybe it got corrupt or something.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .