0

Using iTunes 11.0.1, I tried to add some newly converted movies to my library for consumption on my Apple TV 2. This used to work well: ripping some movies from my DVDs, converting them using HandBrake with the AppleTV or AppleTV 2 setting and adding them to my media library. However, now nothing happens when I add the movie using Cmd-O in iTunes or via Drag-And-Drop from the Finder. Opening the movie via right click in the Finder in iTunes works however, and I can even stream to the AppleTV then. So what's wrong? I checked in the console logs, and can't find any iTunes related error messages.

4 Answers 4

1

Are you sure you're looking in the right Media section of your library? Try looking in Music Videos, TV, etc, in case iTunes is putting it in the "wrong" section.

2
  • Yes. I even searched in the whole media library using iTunes' search.
    – Arne
    Dec 24, 2012 at 23:52
  • I just added a bunch of MP4 container files, encoded with HB's H.264 (x264) codec and AC-3 pass thru. iTunes doesn't normally like AC-3 pass thru (it doesn't usually play), but it added the files just fine. Try backing up your iTunes Library, and then deleting it (or log in as another/new user). Does it work with a fresh library?
    – jimtut
    Dec 27, 2012 at 19:13
1

I've found if you switch to the list view before adding it seems to work much better.

0

iTunes doesn't play well with items added via ⌘ cmd+O, so just transfer your media file into the MusiciTunesiTunes MediaAutomatically add to iTunes folder. Make sure iTunes is not running when you do this, then when you start it up, it should show the file under 'Movies'.

2
  • Why do you propose to have iTunes not running during the file move? I use it all time with iTunes running and it picks up any files moved into that folder within seconds.
    – nohillside
    Sep 22, 2013 at 8:52
  • 1
    I used to do that too and it usually worked, but it occasionally hung iTunes and caused it to be unresponsive. So I've proposed that just to be safe. Sep 22, 2013 at 9:46
0

Since iTunes 11 I haven't had these problems anymore. So I guess somewhere along, this seems to have been fixed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .