Now that podcasts can get auto-downloaded directly to my iphone, i no longer need to sync with my mac but when i use itunes on my mac, i constantly see podcasts downloading. Given that i never listen to podcasts from my mac, is there any way I can stop these from downloading to my mac without causing issues with my iphone?


The way I did it was to plug my iPhone into my Mac as I would normally to sync it and then select the iPhone in iTunes and go to the 'Podcasts' menu to disable 'Sync Podcasts', clicking on Apply to confirm the change. Once I was sure this was disabled, I re-synced my iPhone and double checked there were no issues as the fix was still easy at this point! There were none so I moved onto the next phase - now you can either:

  • Delete the podcasts from iTunes altogether (I did this as my main aim was to save space on my SSD), or
  • Change the iTunes podcasts settings to only update manually (i.e. if you don't click on Refresh in the podcast section of iTunes, they will not download)

It's been a couple of weeks for me and no problems so far.

Hope this helps! Sorry I can't put up any screenshot to help guide you through yet, I don't have enough reputation points to do this yet as I've just discovered this board :)


As far as I know, subscribing to a podcast in the Podcasts app for iPhone will not affect your podcasts in your iTunes library. In iTunes 11, you can simply click "Unsubscribe" under the name of the podcast to stop receiving it on your computer. enter image description here

Then, since you don't listen to podcasts on your Mac anyhow, follow user iteles' suggestion and delete them from iTunes altogether (Ctrl-click its name in the sidebar and click Delete).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .