5

Text that is copied from a web browser and pasted into the native Stickies app often brings text highlighting along with it and I haven't been able to find a way to remove the highlighting within Stickies. My current workaround is to paste the text into MacVim and then re-copy and paste it into Stickies.

Is there a way to remove highlighting within Stickies? Even better would be a way to remove all text formatting within Stickies.

7

I suggest that you try the “Paste and match style” menu command, right below “Paste” - the corresponding shortcut is ⇧–⌥–⌘-V. It will paste the content, but strip all the associated formatting.

3

You make a new sticky note, type in a word (for example "test") and select it.
Click right, go to fonts and then style.
Make the word in the style you want and add it to your favourite styles and give it a name (for example "MyStyle"). And save it.
Now, delete the sticky your just made.

Go to your sticky with the "problem" and select all.
Right-click and go to fonts and style
Click on favorite styles and select "MyStyle"
Click apply

This should do the trick.

1

Highlight all the text and right-click, go to font>styles and you can just click 'apply' to make all the styles match.

0

Text formatting can be changed by selecting the relevant text and typing Cmd-T.

  • Yes, that brings up Font -> Show Fonts. In that menu, I can change the text, underline and strikethrough colors, but I don't see highlighting color as an option. – amacy Dec 23 '12 at 10:09
  • Isn't the last of the four options at the top of the dialog the highlight color? Or is this only the background? – nohillside Dec 23 '12 at 10:17
  • In Stickies the 4th color option is unresponsive... – amacy Dec 23 '12 at 10:22
  • Hmm, works here. Did you try it with a new note (one not pasted from the browser) as well? – nohillside Dec 23 '12 at 10:39
  • I just tried that and it didn't work, either. Perhaps this is a bug corrected in a newer version of OS X? I'm still running 10.6.8 (haven't upgraded because of CS4 compatibility fears) – amacy Dec 23 '12 at 10:52
0

I found a solution. Open up a Microsoft Word document and paste it there, then click the Remove All font option in the menus. Afterwards, you'll be able to copy and paste into the Stickies without highlightings.

  • The Word document approach works. Copy the unwanted highlighted text from Stickies and paste it in a new word document. Make sure it's highlighted and go to the Highlight Icon and select NONE from the dropdown menu. Copy and paste back into Stickies. The highlight should be gone. Thanks "Word solution" person! – John Mendes Apr 25 '18 at 22:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .