Help! I've installed boot camp and Windows 7 on my black Macbook Santa Rosa (2.4Ghz, 4GB RAM) and have a serious problem where I can no longer boot into OSX. OSX freezes with the apple logo and timer, but also has an extra progress bar that I have not seen before.

Has anyone else encountered or heard of this problem?

This is the second time that this exact thing has happened (the last time I just reinstalled everything, as I wanted to increase the size of the windows partition anyway), but really don't have the time to go through all of that again. The first time that this happened, I ran disk utility from the Snow Leopard disk, and attempted to verify permissions and disk but to no avail.

Any help would be most appreciated...

  • Do you get the boot sound or does it stop before that? – conorgriffin Feb 1 '11 at 19:01
  • When you say that you tried to verify permissions but to no avail, what do you mean? Did you verify permissions but still couldn't boot or could you not verify permissions? – conorgriffin Feb 1 '11 at 19:11
  • Start the computer in Verbose Mode (Cmd + v) and see if you can see a specific error message. – drfrogsplat Feb 2 '11 at 6:51
  • @ drfrogsplat - Thanks for that. Now I can boot into OSX again! I didn't know about starting in verbose mode until now. Could not fix some problems. I verified disk and permissions with disk utility from OSX, which reported that my disk needs to be repaired, and also reported permissions problems with airport utility, and i-Life media browser. Not sure what wether that sheds any light on what causes the problem - I made some notes of what the computer was reporting in verbose mode too, if you are interested(I fully understand if you aren't!). Thanks again for the tip :) – user3219 Feb 3 '11 at 10:48

Can you start it in Safe Mode?

Method is explained here: http://support.apple.com/kb/HT1455

|improve this answer|||||
  • @ Griffo - Thanks for the reply. Yeah, I got the boot sound first. I tried to verify the disk previously from the OSX CD(last time this happened), and I could not verify permisssions. However, thanks to drfrogsplat, I've got a bit further this time - if you are interested, read on... – user3219 Feb 3 '11 at 10:44

did you fix the problem in the end? I just had exactly the same problem.

Been working in windows 7 (64 bit) all day while using MacDrive to access the project files I was working on from the mac partition. Tried to boot back into mac os and had exactly the same problem.

Wasn't sure if it was windows 7 or MacDrive breaking things...

|improve this answer|||||
  • This was good to see what was going on: Start the computer in Verbose Mode (Cmd + v) and see if you can see a specific error message. – user3219 Apr 10 '11 at 21:44
  • I had a lot of errors from the airport card, but didn't bottom the problem out tbh. I just ran Disk Doctor in the end and that sorted it out. – user3219 Apr 10 '11 at 21:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .