0

My Contacts (accessible via Mail or the Contacts applications) are read-only on my Mac Book Pro running Mac OS X 10.8.2. Contacts reports itself as Version 7.1 (1167).

I have 5 total contacts currently, including Apple and "Me". Not sure what I did to add the other 3, but they cannot be modified or deleted, nor can I add any new ones.

If I add or edit a contact it behaves normally, until I close Contacts. When I reopen it then all the changes are gone.

I thought maybe the contacts folder was read-only in my Library, and thought I double checked that, but maybe I missed something.

The interesting thing is both the "On My Mac" and "iCloud" contacts are read-only.

  • 1
    Have you tried repairing permissions of your startup Volume with Disk Utility? You can also export the contacts with File>Export...>Contacts Archive..., quit Contacts, rename ~/Library/Application Support/AddressBook, start Contacts (with will only include Apple and you) and import the exported contacts. – jaume Dec 18 '12 at 11:00
  • I'm glad it worked. I expanded my comment to an answer as you suggested, see below. – jaume Dec 19 '12 at 9:30
1

It looks like there is, as you mention, a file permission problem, or maybe the Contacts database is corrupt.

In either case, try rebuilding the database:

  1. Open Contacts and export your contacts with File>Export...>Contacts Archive....
  2. Quit Contacts.
  3. Open ~/Library/Application Support/ in the Finder (you will need to switch to the Finder, press ShiftG, type ~/Library/Application Support and press Enter).
  4. Rename ~/Library/Application Support/AddressBook to ~/Library/Application Support/AddressBook.bak.
  5. Start Contacts. You will notice that there are only two contacts: Apple and you. Delete them.
  6. Import the previously exported contacts with File>Import....

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .