diskutil list shows what I am fairly certain is the correct layout. The recovery partition is "outside" the core storage logical volume group on the rotational disk:

% diskutil list   
   #:                       TYPE NAME                    SIZE       IDENTIFIER  
   0:      GUID_partition_scheme                        *120.0 GB   disk0  
   1:                        EFI                         209.7 MB   disk0s1  
   2:          Apple_CoreStorage                         119.7 GB   disk0s2  
   3:                 Apple_Boot Boot OS X               134.2 MB   disk0s3  
   #:                       TYPE NAME                    SIZE       IDENTIFIER  
   0:      GUID_partition_scheme                        *750.2 GB   disk1  
   1:                        EFI                         209.7 MB   disk1s1  
   2:          Apple_CoreStorage                         749.3 GB   disk1s2  
   3:                 Apple_Boot Recovery HD             650.0 MB   disk1s3  
   #:                       TYPE NAME                    SIZE       IDENTIFIER  
   0:                  Apple_HFS Macintosh HD           *865.3 GB   disk2  

If I mount it, I see:

% ls /Volumes/Recovery\ HD/  
System          com.apple.boot.P    com.apple.recovery.boot  

% df -h /Volumes/Recovery\ HD/  
Filesystem     Size   Used  Avail Capacity iused ifree %iused  Mounted on  
/dev/disk1s3  620Mi  500Mi  120Mi    81%  127917 30773   81%   /Volumes/Recovery HD

So clearly something's there. Yet, if I hold down option, all I see are the two copies of the fusion drive (does anyone know why home made fusion drives do that and Apple's don't?).

I attempted to

bless -folder /Volumes/Recovery\ HD/System/Library/CoreServices -bootefi /usr/standalone/i386/boot.efi

but that didn't do anything.

I can't help but think that the recovery partition is mostly there and just needs a small "kick" to make it work. I certainly don't think it's worth reinstalling Mountain Lion and restoring from time machine to fix this.

The output of diskutil cs list was requested:

% diskutil cs list
CoreStorage logical volume groups (1 found)
+-- Logical Volume Group 748D74CE-EBC8-4A7F-985F-239E699255CF
    Name:         FusionDrive
    Status:       Online
    Size:         868986765312 B (869.0 GB)
    Free Space:   0 B (0 B)
    +-< Physical Volume 2CC32F7C-2358-484C-A885-5757E9AF6CFC
    |   ----------------------------------------------------
    |   Index:    0
    |   Disk:     disk1s2
    |   Status:   Online
    |   Size:     749296615424 B (749.3 GB)   
    +-< Physical Volume 4C8685E8-30DA-41FA-A37D-3BD6E83F9240
    |   ----------------------------------------------------
    |   Index:    1
    |   Disk:     disk0s2
    |   Status:   Online
    |   Size:     119690149888 B (119.7 GB)
    +-> Logical Volume Family 6A089C96-ACEF-4B36-BF56-7E56C42B1294
        Encryption Status:       Unlocked
        Encryption Type:         None
        Conversion Status:       NoConversion
        Conversion Direction:    -none-
        Has Encrypted Extents:   No
        Fully Secure:            No
        Passphrase Required:     No
        +-> Logical Volume CD4DEF37-AAA0-4F74-AD1B-A7DE08E3D4CE
            Disk:               disk2
            Status:             Online
            Size (Total):       865261846528 B (865.3 GB)
            Size (Converted):   -none-
            Revertible:         No
            LV Name:            Macintosh HD
            Volume Name:        Macintosh HD
            Content Hint:       Apple_HFS

Note that the fusion drive itself seems to be working fine. The only difference I can tell in using it between it and a real Apple one is that in the option menu, I see two copies of "Macintosh HD" (both will boot it up). And, of course per this question, no Recovery HD.

  • Can you add the output of diskutil list?
    – nohillside
    Dec 17, 2012 at 15:37
  • Can you post what diskutil cs list says?
    – duci9y
    Dec 17, 2012 at 16:13

2 Answers 2


Well, I was able to "solve" this in a round-about way.

I used the recovery disk assistant with my MacBook Air to make a recovery SD card. With that plugged into my mini, I was able to successfully boot into it and the disk utility there was able to comprehend my fusion drive.

That done, I then checked and saw that the recovery partition on the SD card was the same size as the recovery partition that wasn't working right, so I did a dd from the SD card overwriting the recovery partition.

The result: my option menu now offers the choice of the fusion drive (booting normally) or the recovery partition, and both work.

What I think may have been going on is that core storage seems to want to turn the recovery partition into a 'boot helper' on encrypted volumes. Perhaps it was trying to do the same thing on this machine, despite the fact that there was a separate boot partition intended to serve that purpose.

I'm not going to mark this as "solved," however, because I think there has to have been a better way.

  • Alas, this is unsolved. I tried it again today, just out of curiosity, and it's back to having two copies of "Macintosh HD" in the option menu, both of which just boot the machine as normal. Option-R starts Internet recovery, which is Lion and does not understand the fusion drive.
    – nsayer
    Dec 22, 2012 at 3:52
  • Should we delete your answer entirely or might an edit to incorporate the comment be more useful to let others know what won't work but give them a line of thought / plan of attack in case they can finish the task?
    – bmike
    Apr 4, 2013 at 19:10

The reason that the recovery partition doesn't work correctly, is that a Fusion logical volume group is not bootable (or at least not for the purposes of a recovery partition - a Fusion volume requires some kind of boot-loader to interpret the LVG). And if you create the fusion volume prior to installing Mountain Lion the recovery partition gets created inside the Fusion volume.

The way that I managed to create a DIY Fusion drive with a correctly working recovery partition is as follows.

  1. Format the SSD to a single JHFS partition.

  2. Install Mountain Lion from your USB as normal to the SSD. (This is when the recovery partition gets correctly created on the SSD).

  3. After installation, unplug your USB stick and boot into recovery mode (CMD + R)

  4. Now create the LVG and Fusion volume in Terminal, but instead of choosing the entire SSD, choose only the main OS partition (in my case, this was something like disk0s2 instead of disk0). This way the bootable recovery partition you just made on the SSD remains intact.

  5. Then install Mountain Lion from recovery (without the USB inserted - allow it download the OS again from the internet - this way the installer knows not to create a second recovery partition as the Mac must already have one to run this type of installer).

After performing these steps, I've got a DIY Fusion running great and a correctly functioning recovery partition on the SSD (outside the Fusion volume).

[N.B. I did not try installing the second time around from the USB installer. It's quite possible that the installer would correctly identify the recovery partition and not create a second one inside the Fusion volume, but I figured that using the internet installer was a sure way to make it work correctly and I can confirm that it does. If you install the second time from the USB stick and you do end up with two recovery partitions - one inside and one outside the fusion LVG - I'm sure you could fix this in a few steps by removing and resizing partitions in terminal.]

Also, my OPT+BOOT menu still shows two Fusion volumes and no recovery partition. But booting with CMD+R works perfectly.

  • But as you can see from the cs list output in the question, both the recovery partition and the bootloader partition are outside of the LVG, and yet the recovery partition doesn't work.
    – nsayer
    May 1, 2013 at 19:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .