My computer is a 15" Macbook Pro with Retina display, and I'm on OS X version 10.8.2. I have had this my computer for several months.

In the past few days, the computer has been completely "hanging", where nothing moves on the screen except the mouse pointer. If I was on a Skype call, the call goes on like normal, but I can't do anything else on my computer. Gestures don't work, so I can't switch desktops. I can't use my keyboard to quit the current application. I can't click on anything. The entire screen is completely unresponsive. The only way out is to force the computer to shut down. Then it boots up normally. It's only been happening recently, and I haven't been able to identify the cause.

Could it just be a bug that Apple needs to fix? Is there a process/app that could cause this to happen? How do I determine what caused the computer to hang?

Edit: In the Console, I do see this message many times before the reboot:

1/12/13 7:03:46.000 PM kernel[0]: vtd[0] fault: device 1:0:0 reason 0x5 W:0x1130e000

I have no idea what this means, but I thought it might be related because it does happen immediately before the bootup entry.

Edit 2: On other freezes, I see this message before a boot:

1/12/13 9:06:51.000 PM kernel[0]: NVDA(OpenGL): Channel exception! exception type = 0xd = GR: SW Notify Error

Edit 3: The problem was a faulty graphics card. I sent my computer in to Apple a while ago and they replaced the logic board, and when I got it back everything was hunky dory.

  • Does anything in the Console look suspicious? Install any new software recently? – vcsjones Dec 17 '12 at 0:33
  • Not that I can tell. I believe the last thing I installed was LineIn, which is a very simple audio play-through app. – Hassan Dec 17 '12 at 0:41

If you can't launch or switch programs (I find Spotlight is a good way to do this if everything else is hanging, just hit ⌘Space, but it may not work in your case), you could enable SSH access ahead of time, and then use another device to log in and check what's hogging your CPU.

Open Sharing Preferences and enable Remote Login. Then you can connect via SSH from another Mac, PC or iOS device (you'll need PuTTY on Windows, and one of various SSH clients available on iOS). Once you're logged in, type top -o cpu to get an updating display of processes ranked by CPU usage. That should give you a hint as to what's causing the problems.

  • Okay, I tried this. I waited for the computer to freeze, and it dutifully obliged. Then, I logged in to my account via SSH (on my phone, the only accessible device at the moment), and ran top. The #1 process was always kernel_task, with 13% of the CPU. After I restarted and ran top in the terminal, kernel_task is only getting about 4%. I'm guessing this could be because of the SSH server running (maybe in a driver or something?). I also noticed that the process netbiosd, among others, is in the state "stuck". I don't know the significance of that, but I thought I would mention it. – Hassan Dec 17 '12 at 4:45
  • So does this mean anything? Also, here is a screenshot with top running. I took a few to try to make sense of the problem. Thanks for a great answer, by the way. – Hassan Dec 17 '12 at 4:47
  • looking at your screenshots I also see netbiosd, WindowServer and ntpd are 'stuck'. my guess is WindowServer is causing it. try sudo killall -HUP WindowServer this should restart WindowServer. But be careful WindowServer is used to draw anything on your screen so it will kill almost everything else as well But it beats rebooting and you now have a starting point to fix your problem if this fixes your "hanging" problem. – FLY Jan 14 '13 at 11:24

vtd is not well documented on OS X. I did find one post on InsanelyMac (hackintosh forum) suggesting that it has to do with Intel's VT-d technology, which allows virtual machines to access hardware more efficiently.

By the console message, it looks like the problem is coming from a kernel extension. I would suggest running the OS X 10.8.2 combo update, which hopefully will overwrite any offending kexts with good copies.

If that doesn't fix it, your next best option is to file a bug report with Apple since not a lot of people share this issue. They take awhile to respond, but things will eventually be fixed.

  • When I ran kextstat, I did get four kexts from Virtual Box (a virtual machine app). There's also a CUDA kext, and a SoundFlower kext (an audio driver). Based on your answer, I'm starting to suspect the Virtual Box drivers. I'm going to unload them and see if the problem persists. – Hassan Jan 13 '13 at 3:48
  • @Hassan where you successful? I believe I may have the same problem. – thefonso Jan 13 '13 at 17:11
  • @thefonso It hasn't been long enough to know for sure yet, but I haven't had the problem so far. My graphics performance is pretty bad now for some reason, but I think that's unrelated to this problem. When you run kextstat | grep -v com.apple, do you see any VirtualBox kexts? – Hassan Jan 13 '13 at 18:55
  • @thefonso You know what, 2 minutes after I wrote that comment, the computer froze and I had to restart. I'm afraid That didn't fix the problem. – Hassan Jan 13 '13 at 18:59

I propose running Force Quit Applications by pressing cmd ⌘alt ⎇esc. Then you may see which application is Not Responding, and you can kill it by pressing the Force Quit button.

Although above method is my last choice when I face a hang condition, there is a another choice before it: Try to run Activity Monitor from Applications->Utilities. There you may click on the % CPU column header to see which processes are eating the CPU. Then you may select a process and press Quit Process button above the same window to kill it.

Although in hang condition the second method is hard to do, in some cases could be a better choice because it shows information of all processes that may be not listed in the first method.

  • Thanks, but I can't do those things because the computer is completely unresponsive (except for mouse movements). Apps continue to run, but clicking on anything on the screen, inputting keyboard shortcuts, or using gestures on the trackpad don't do anything at all. – Hassan Jan 13 '13 at 2:13
  • 1
    Try to keep activity monitor running full screen in the background and maybe you'll catch what it is the next time it freezes. – asmeurer Jan 13 '13 at 4:48

Question: What happens if you plug it into a second monitor? Do BOTH screens freeze? or just the Retina display?

Question #2: are your mouse clicks registering? For example, could you drag to select something, or even play music in iTunes with the mouse?

IF: Both screens freeze BIG issues. Could be logic board (non video card related) HD, HD cable, Display, etc.... They would start with least invasive first.

IF: Main screen freezes, but not secondary. Video Card. Try switching off the secondary video card, or the auto switching, and see if that makes a difference.

IF: Mouse clicks are registering HD is not the problem, and neither is the Video card ( 80% sure) sounds like the cable for the display has failed, or is failing, and the display needs to be replaced.

Suggestion PRE solution: Use Quicktime and do a screen recording, and then try and make your computer freeze. If it continues to record, and you are able to move items, etc... then its a display/video card issue.

Either way, warranty support. Make a backup first, then get to your local apple.


The first thing I usually do when I noticed an odd behaviour is repair the boot disk and disk permissions, then reboot while holding the Shift button to get into safe mode and find out if the computer would still hang.

If the computer doesn't hang then at least I know none of the OS essential files is causing this.

After that you can start troubleshooting the problem taking into account your last installed applications or last updated ones in the past few days.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .