When I plug my iPhone 4 into my Windows 7 Ultimate laptop, it syncs just fine with iTunes, but it no longer mounts on the desktop for me to transfer pictures and videos.

When I plug it in, Windows attempts to install a driver named "MTP USB Device" and then fails.

I've tried a number of things, the most drastic being:

  • Uninstall iTunes
  • Uninstall MTP USB Device from Device Manager
  • Restart
  • Install the latest iTunes
  • Restart
  • Run iTunes
  • Plug in the Phone

When I did that, Windows claimed it was installing a driver named "iPhone" (yippee!) but then it switched to "MTP USB Device" and failed again.

I've searched other forums and found strange and bizarre ideas that include exploding the iTunes MSI so I can get the Apple USB Device driver -- but that driver is installed and works just fine.

  • 3
    I came to say "me too", but then realised it was my questions in the first place. Bounty time. Commented May 9, 2011 at 3:38
  • I'm not saying this is off topic, but most people who answer questions here are Mac users. Since you're really looking for a Windows user to answer your question, you may have more luck over at Super User. (If you decide to try SU, don't cross-post -- ask a moderator to migrate this question for you.) Either way, I hope you find an answer soon!
    – Austin
    Commented May 9, 2011 at 4:39
  • This is an iPhone question. I don't want to argue with you about what should be here and what should not be but instead should allow any type of question that relates to apple devices and software.
    – user6124
    Commented May 9, 2011 at 8:58
  • @bckbck What @Austin said is not that the question should not be here, but that he will get better luck on SuperUser. The reason (and I agree) is that as much as we (as an Apple community) may know about an iPhone, not a lot of users here have Windows experience (or enough Windows experience to come up with a solution). We DO allow these questions, only after a couple of days we suggest migrating over SU if the question warrants it. This is more a Windows problem (i'm sure if he tries his iPhone in a new Windows computer it will work). Commented May 9, 2011 at 9:14
  • @Martín Thanks for clarifying. I've had a previous run-in with that user responding defensively about a migration suggestion, so it's nice to have some sane, reasonable backup this time. :]
    – Austin
    Commented May 10, 2011 at 23:55

5 Answers 5


In the mist of giving you an extra idea, and to be frank I have no idea what your problem might be, let me share what I'd do to find the cause and -eventually- fix it.

You seem to have done your Windows homework well, yet results haven't been what you expected. Something I remember doing with Windows when things didn't work (in the Windows95 era this was very common!) was rebooting in Safe Mode and see if anything looked unfamiliar.

In any case, if you still can't manage to make Windows work, before anything else, it would be interesting to make sure that the problem is not in the iPhone itself (probably nothing that an iPhone restore wouldn't fix if that's the case).

First rule of diagnosing a problem: try it on another system. The result of this simple test is going to rule out 50% of the possibilities.

If it works, the problem is in your Windows machine and you might get better luck at Super User (since our userbase here has less Windows experience, tho we have a few geeks around).

If it doesn't work, then the problem is not your Windows (stop removing stuff or it will go coo-coo!).

In that case, you might want to perform a full Restore of your iPhone. I am not familiar with Windows+iPhone combo, but don't you have to Check some preference in iTunes for that "mounts on the desktop for me to transfer pictures and videos" thing to happen? I think it was called "Enable Disk's use" on iPods, but I haven't seen that option in iPhones, but then again, Maybe on Windows this is common. Forgive my ignorance in the subject.

Anyway, just make sure your iPhone mounts on another computer's desktop (with Windows) before destroying your own Windows. For what is worth, I'm not aware of any iPhone mounting on a Mac's desktop, this has got to be a Windows thing, and this is why Super User may be better suited.

  • +1 for good, basic, cross-platform troubleshooting tips.
    – Austin
    Commented May 10, 2011 at 23:56
  • Yeah, this is pretty good isolation. First I generally check if it is user or system wide, but drivers are system wide. Commented May 14, 2011 at 20:01


I had this problem with my PC (windows 7, 64-bit) and my iPad. After messing with it for a long time, I finally found the answer (bad USB driver). The following two step process should help resolve these kinds of problems more quickly.

The first step is to verify that the iPad (or iPhone) is really connected to your computer. This can be (really) checked using a program called USBDeview. You can get this (very small) program from download.cnet.com/USBDeview/3000-2094_4-10614190.html or www.nirsoft.net/utils/usb_devices_view.html. Don't worry, it's not Spyware or Malware.

Just run the program and sort on the 'Connected' column. If your iPad or iPhone doesn't show up as Yes (under 'Connected') then your iDevice is not properly connected to your computer. Could be a cable problem. Could be an iDevice problem. Could be a USB hub problem. Note that your iDevice might be listed as what it is (iPad or iPhone) or it might be listed as 'Apple Mobile Device USB Driver' in the 'Description' column.

Apple has a number of ideas to resolve this sort of basic connectivity issue, including switching USB ports, resetting your iDevice, rebooting your iDevice, rebooting your computer, etc. You will need to try them until your iDevice shows up in USBDeview as 'Yes' under Connected.

If you iDevice shows up as 'Yes' under connected, it should also be visible in the Device Manager (found in the Windows 7 Control Panel under Hardware and Sound). You might find it under Portable Devices or it might be under Universal Serial Bus controllers.

The iDevice may or may not show up in the Windows Explorer. On some machines it does, on others it does not. Why is not clear.

If the Idevice is properly known to Windows and iTunes can't see it, then any number of other things could be wrong. Apple has a list. See the very useful page over at http://support.apple.com/kb/TS1538. Testing shows that the Apple Mobile Device service must be running. Check this using Task Manager (started by right clicking the taskbar). Note that the iPod service and the iphlpsvc service must also be running. These services have different names under the Processes table versus the Services tab of Task Manager.

AppleMobileDeviceService.exe - Apple Mobile Device iPodService.exe - iPod Service ItunesHelper.exe - iphlpsvc

Step 4 of http://support.apple.com/kb/TS1538 checks if the Apple Mobile Device USB is installed. This is essential and a common source of problems. In at least some cases, Windows will install the 'MTP USB' driver. Indeed, Windows will reinstall this driver if you uninstall it. The MTP USB driver is essentially a Windows bug (possibly caused by Microsoft). You MUST replace the MTP USB driver with the Apple Mobile Device USB Driver. Step 4 explains how to do this. Note that you MUST use the 'Have Disk' approach. Otherwise, Windows will just reinstall the invalid MTP driver.

The Apple doc indicates that you can find the correct driver at C:\Program Files (x86)\Common Files\Apple\Mobile Device Support\Drivers. Perhaps this is correct on some systems. You may find the correct driver in C:\Program Files\Common Files\Apple\Mobile Device Support\Drivers.

iTunes could make this a lot easier by checking if the iDevice is known to Windows (what USBDevier does) and if the Apple Mobile Device USB driver is properly installed for the iDevice. Sadly it doesn't perform either check. Note that iTunes does if some of the related services (see above) are actually running.


I had the same problem and this sorted it out permanently

  1. Click the windows button (start) – in the box where it says search programs and files type “run”
  2. Under programs at the top of your start menu, it should now show Run, click on this.
  3. In the dialog box of the run program type “regedit” and click ok,when windows prompts do you want to allow the program to make changes click on YES
  4. The registory editor window will now open, before doing any more backup the current registry to a location you chose by clicking on file>export- name the file and click save
  5. In the left hand split of the registory edit window browse for the following file location HKEY_LOCAL_MACHINE / SYSTEM / CurrentControlSet / Control / Class
  6. On the left side, search for the entry {EEC5AD98-8080-425F-922A-DABF3DE3F69A} and click on it (it will be close to the bottom of the file list in the class folder)
  7. On the right side, you will find a key which begins with “Upper…” – delete it!
  8. Now unplug your iPhone
  9. Restart your computer
  10. Plug in your iPhone and hopefully find it mounted as a drive again!
  11. Double click my computer, double click iphone, double click internal storage and double click DCIM, you can now select your pictures and copy/paste or drag to the desired location.

I had pretty much the same issue, and nothing worked for me. But when I disabled the MTP USB in Device Manager, I was able to connect my iPhone to my PC again.


Two things: First, Microsoft's Answers recommends not just uninstalling your iPhone drivers, but all USB drivers.

I have heard rumors of laptop webcam drivers interfering with the iPhone's camera drivers before, and there is mention of it on iPhone, iPad, or iPod touch: Device not recognized in iTunes for Windows, though this specific problem is a less serious incarnation of the entire device not showing up.

Secondly, have you tried an alternate USB port?

Lastly, if you're going to restore your device, make sure to follow This article.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .