While testing WordPress 3.5, I took the old copy of a site, and copy pasted the 3.5 from the zip file.

Part of a WordPress install is the folder wp-content containing all the uploads and themes plugins etc. This folder now no longer contains all of that stuff because I clicked replace.

How do I replace the files in that folder, not the folder itself? Right now it's the same as deleting that folder and then moving the new folder in its place.

Under Windows, the files in the folder, not the folder itself are replaced, right now i'm lucky I have a backup to copy from but I could very easily have lost that date considering every other platform I use follows one paradigm and OS X another

Some people have suggested I should click on merge, this would be great if I could, but no merge option is provided:

enter image description here

enter image description here

  • 1
    If you have 10.8, clicking on “Merge folders” instead of “Replace folder” will have done the trick. – duci9y Dec 14 '12 at 16:47
  • 1
    hmmm I'm on the latest OS X with the latest macbook air and all the updates and firmware improvements, and did not see that option – Tom J Nowell Dec 14 '12 at 17:08
  1. Select the folder you wish to copy.
  2. Press command + C. This will copy the folder to clipboard.
  3. At the destination, press command + V. This will copy the folder to your current folder. If a folder with the same name exists, you will be give options to Stop, Merge or Replace.

Quirk: This doesn’t work if you try to move (by dragging), not copy, a folder from one place to another. However, if you still wish to use dragging and dropping, drag with the option key pressed. This will copy, instead of move, a file/folder from one place to another.

This is what you will see if you copy a folder named “Temp” to a folder named “untitled folder” which already contains a folder named “Temp”. enter image description here

| improve this answer | |
  • 1
    No merge option is provided, I am presented with 'skip' 'stop' or 'replace' – Tom J Nowell Dec 14 '12 at 17:58
  • What exactly are you copying? Are you copying files inside a folder to another folder or copying a folder to a place which contains a folder with the same name? – duci9y Dec 15 '12 at 7:35
  • I tried copying both files and folder, and I tried copying a folder, the results of both can be seen in the screenshots in my question. E.g. I tried to copy everything you would get in a wordpress install, and I tried copying the wp-content folder into a folder that already had such a folder. No merge buttons were displayed, nor have I ever seen a merge button when doing Finder operations in OS X – Tom J Nowell Dec 15 '12 at 23:35
  • That’s not normal. It can be a permissions issue. Try copying stuff to and from your Desktop/Documents folder. If a merge option appears, it’s a permissions issue with wp, and if a merge option doesn’t appear, you are probably doing something wrong or the problem is deeper than it appears. In that case, only a person with physical or VPN access will be able to help you. – duci9y Dec 16 '12 at 6:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .