11

I have the screen saver on my Mac password protected, but unlocking the screen saver does not unlock the login keychain. I know this because I get asked to unlock the login keychain shortly after unlocking the screensaver.

Yes, my login password and keychain password have been synchronized.

Yes, I've run Keychain First Aid and confirmed there are no problems.

The workaround is to change the Keychain Settings so the login keychain never automatically locks, but I'd prefer to have it lock automatically, especially on my laptop when it goes to sleep, but now with Mountain Lion and iCloud that means typing my password twice every time I wake my laptop: once for the screensaver and once for the keychain.

There should be a way to make the screensaver also unlock the keychain just the way the normal login also unlocks the keychain. Is there?

  • I'm actually missing the usefulness of locking the keychain in addition to locking the screen. Couldn't you just set the keychain to never lock and let the OS ask you your password whenever it comes back from sleep? – Saaru Lindestøkke Feb 15 '15 at 19:58
  • I tested exactly what you're talking about by setting my Login keychain to lock on sleep and I can watch the keychain lock on sleep and unlock on wake without a password prompt. Do you get prompted for your Login keychain password at other times, like on reboot? What version of OSX are you running? – Todd Dabney Apr 16 '17 at 21:48
  • @ToddDabney "lock on sleep" is not the same as lock when the screen saver activates, nor is "unlock on wake" the same as unlocking when deactivating the screen saver. – Old Pro Apr 17 '17 at 18:07
  • In a later paragraph you referred to your computer going to sleep, that's why I focused on that. Since that works doesn't it make more sense to slightly alter your workflow with sleeping your computer? Then you get your keychain lock and unlock? – Todd Dabney Apr 17 '17 at 19:30
-1

This usually happens when you change your login password without changing your keychain password.

  1. Open Keychain Access
  2. Click Edit -> Change Password for Keychain 'Login'
  3. Match the password to the one you log into the computer with.
  • This is not the problem, as I tried to indicate by saying "Yes, my login password and keychain password have been synchronized." – Old Pro Apr 11 '13 at 1:09
-2

I have read that you ran Keychain First Aid,

but you were not clear about checking your "Keychain First Aid" preferences (under Keychain Preferences): you can choose there to never lock the keychain while logged in, and re-run First Aid.

Also, if you right-click on the keychain, which requires a manual unlock, and then choose keychain settings, there is an option to lock the keychain after x minutes of inactivity or at system sleep.

My guess is that the first setting might be activated.

  • Like I said, "The workaround is to change the Keychain Settings so the login keychain never automatically locks, but I'd prefer to have it lock automatically" – Old Pro Jun 2 '13 at 21:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .