2

Somehow I have a problem (previously everything was ok), hosts form /etc/hosts can't bre resolved.

I have local domain in /etc/hosts, like

127.0.0.1 test.local

It's loading in browser well but too long, from firebug i see that biggest part of time spending for DNS lookup.

I tried nslookup test.local

I see

$ nslookup test.local
;; connection timed out; no servers could be reached    

but ping test.local working well :)

my DNS settings are next:

$ cat /etc/resolv.conf 
nameserver 192.168.1.1

I did not modified that file manually, it just represent GUI settings situation.

    $ scutil --dns
    DNS configuration

    resolver #1
    nameserver[0] : 192.168.1.1
    reach    : Reachable,Directly Reachable Address

Everything become solved if I turn OFF mac os included firewall. How I can make local pages opening faster and keep firewall turning ON ?

  • We are experiencing this issues since Sierra (we = several machines). Everytime we enter a certain network with assigned DNS via router hosts file is ignored. Simple solution: Switch DNS provider on router. But this is necessary every morning :-( WTF? After this it resolves again against local hosts file. – Strinder Feb 7 '17 at 12:05

You must log in to answer this question.

Browse other questions tagged .