I have integrated both twitter and facebook account to my macbook-pro. I am getting notifications perfectly. The only problem I have is that I can't post via notification center. There're 2 buttons Click to post, one each for twitter and facebook, which used to work fine previously. Now suddenly they stopped responding. When I click on them nothing happens. I can see click animation(pushing of button), but it does nothing, no edit area to post my updates, nothing at all.

How can I get the functionality back?

  • Have you tried removing and resetting the integrazion?
    – Maverik
    Dec 12, 2012 at 0:16
  • Thanks for responding. How do I remove it, by disabling it in notification center or is there any other way?
    – noob
    Dec 12, 2012 at 6:05

4 Answers 4


First, try to repair permissions.

If that doesn’t work, try installing the latest combo update again. This will most likely fix your issue.

If even that doesn’t solve the problem, reinstall OS X and then install the latest update without removing your current installation. Just install it on top of the current installation. You won’t have to mess with backing up/restoring and you will fix all issues.

  • Well I've installed the combo update, but nothing changed. I don't know how can I repair permissions. Reinstalling a complete OS just for a minor bug, doesn't seem right to me.
    – noob
    Dec 16, 2012 at 12:18
  • Google “how to repair permissions”. And did you install the combo update again?
    – duci9y
    Dec 16, 2012 at 16:25
  • repaired the permissions, still the same issue persists. And yeah I've reinstalled it the update.
    – noob
    Dec 17, 2012 at 19:01
  • Create a new test user and see if the problem persists. If not, reset your home directory permissions and ACLs (Google how to do that). If yes, then a reinstall of OS X is the only option.
    – duci9y
    Dec 18, 2012 at 8:33

Solved following this guide. You simply have to kill the notification center process.



Have you tried to remove and re-set the integration?

  1. Go to System Preferences > Mail, Contacts & Calendars
  2. Select your Facebook account on the left
  3. Press the button -

The same for twitter.

  • Tried that, didn't work. Same problem. The click doesn't do anything.
    – noob
    Dec 13, 2012 at 7:02

Download the combo update from ... http://support.apple.com/kb/DL1581

Don't forget the supplemental update too ... http://support.apple.com/kb/DL1600

NOTE: As a rule, I never use Software Update for OS updates. I find manually downloading and installing the Combo Update (not the incremental one) .. eliminates a lot of headaches.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .